Pipelines crash caused by shared memory size change (/dev/shm)

Issue #17200 resolved
Emmanuel Viala
created an issue

The shared memory size was changed last week from 512mb to 64mb making CI tests using puppeteer/wdio with chrome headless unable to run. (Very very high chance of crash)

To reproduce:

$ df -h /dev/shm

Current output:

Filesystem Size Used Avail Use% Mounted on shm 64M 0 64M 0% /dev/shm

Expected output:

Filesystem Size Used Avail Use% Mounted on shm 512M 0 512M 0% /dev/shm

We are running CI outside of pipelines until this issue is solved, is there any ETA for a fix ?

Comments (8)

  1. Daniel Egger

    I have the same problem and it is pretty annoying. The cypress crashes very often in our pipeline with the following error:

    We detected that the Chromium Renderer process just crashed.
    This is the equivalent to seeing the 'sad face' when Chrome dies.
    This can happen for a number of different reasons:
    - You wrote an endless loop and you must fix your own code
    - There is a memory leak in Cypress (unlikely but possible)
    - You are running Docker (there is an easy fix for this: see link below)
    - You are running lots of tests on a memory intense application
    - You are running in a memory starved VM environment
    - There are problems with your GPU / GPU drivers
    - There are browser bugs in Chromium
    You can learn more including how to fix Docker here:
    https://on.cypress.io/renderer-process-crashed
    

    It seems to be related to the /dev/shm size. I also tried to make a sixe: 2x run but cypress/chrome is still crashing in my pipeline. Not all the times, some times it works, but more often than not it crashes.

  2. Log in to comment