1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues


Issue #1721 resolved

Can't reset password

Mykel Alvis
created an issue

I logged in/created my account using an OpenID url.

I wanted to delete my private repo and couldn't because I appear to have had no password, so I requested a new password to be sent to me. It was sent, and I tried to use it to reset my password in my account screen and it won't let me do so. The error it gives is oldpw

* Old password is wrong. Please enter a valid password.

I cut and pasted the password and then I receieved via email and then I tried hand-typing it. I requested another reset and this also doesn't work.

I think there's something awry in your OpenID account management.

Comments (9)

  1. anentropic
    • changed status to open

    Well, glad it works for you as I have the exact same problem - I signed up with an Open ID url but I can't login (or more importantly connect via hg client) using the username and password I was sent.

    I just followed the 'forgot password' link on the website and gave it my email. It sent me a new password and I clicked the confirmation link (definitely, because if I click it again it says "confirmation key isn't registered"). But when I try to log in with that password it won't let me. Doesn't work from hg either.

    Furthermore, I can login with OpenID and if I go to the 'change password' screen I can't use the new password I was sent (which should now be my password) as the 'old password'. But I can't change the password, as I don't know what the 'old password' is supposed to be... it doesn't seem to be one I usually use, the one that was originally sent when I signed up (found in old email) or the new one sent by 'forgot password'.

    Am stuck in fact, can't use my private repo.

  2. Mykel Alvis reporter

    Try this:

    1. Click the forgotten password link and get a new password
    2. Close your browser
    3. Get the new password email and click the link in it. This is SUPPOSED to log you in, it seems. If it doesn't then just login with your OpenID.
    4. Go to your account and change your password using the new password you were sent.
    5. Log out and close your browser

    At this point, open browser, log in using username and password and see if that helps. Those are the steps that I followed.

  3. anentropic

    Thanks Mykel, it worked this time. Maybe the important part was step 2... this time after clicking the confirmation link I was able to do a non-openid login with the new password.

  4. Anonymous

    I also have been running in circles for 20 mins because I didn't see the confirmation link at the bottom of the 'change password' email. Is it a good idea if this para could be moved up above the new account details, and the wording which currectly says:

    'Your new account details are:'

    to something like

    'After confirmation, your new account details will be'

    Best regards,


  5. Log in to comment