ssh-keygen invalid file type won't upload (BB-3452)

Issue #1811 resolved
dynomite created an issue

ubuntu 9.10

ssh-keygen --> produces file
attempted to paste key -->failed to accept in account on

attempted to upload file, states invalid filetype.

please advise.

attemtped ssh-keygen -t rsa
attemtped ssh-keygen -t dsa

or ssh-keygen -C "blah " (adding that whitespace?) as mentioned earlier, still no success

Comments (12)

  1. dynomite reporter

    I am unable to add ssh public key... be it through the web interface or command line as shown below.

    $ ssh -v -i /.ssh/ OpenSSH_5.1p1 Debian-6ubuntu2, OpenSSL 0.9.8g 19 Oct 2007 debug1: Reading configuration data /etc/ssh/ssh_config debug1: Applying options for * debug1: Connecting to [] port 22. debug1: Connection established. debug1: identity file /home/xx/.ssh/ type 1 debug1: Checking blacklist file /usr/share/ssh/blacklist.RSA-2048 debug1: Checking blacklist file /etc/ssh/blacklist.RSA-2048 debug1: Remote protocol version 2.0, remote software version OpenSSH_5.1p1 Debian-5 debug1: match: OpenSSH_5.1p1 Debian-5 pat OpenSSH* debug1: Enabling compatibility mode for protocol 2.0 debug1: Local version string SSH-2.0-OpenSSH_5.1p1 Debian-6ubuntu2 debug1: SSH2_MSG_KEXINIT sent debug1: SSH2_MSG_KEXINIT received debug1: kex: server->client aes128-cbc hmac-md5 none debug1: kex: client->server aes128-cbc hmac-md5 none debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP debug1: SSH2_MSG_KEX_DH_GEX_INIT sent debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY debug1: Host '' is known and matches the RSA host key. debug1: Found key in /home/xx/.ssh/known_hosts:1 debug1: ssh_rsa_verify: signature correct debug1: SSH2_MSG_NEWKEYS sent debug1: expecting SSH2_MSG_NEWKEYS debug1: SSH2_MSG_NEWKEYS received debug1: SSH2_MSG_SERVICE_REQUEST sent debug1: SSH2_MSG_SERVICE_ACCEPT received debug1: Authentications that can continue: publickey debug1: Next authentication method: publickey debug1: Offering public key: /home/xx/.ssh/ debug1: Authentications that can continue: publickey debug1: No more authentication methods to try. Permission denied (publickey).

  2. dynomite reporter

    Added some notes on my attempts to resolve the problem on Ubuntu in the help file and have been able to update public key now.

  3. dondonakal

    I successfully added my public by adding the content of the public key, ie.

    ssh-dss xxxxxx

    (without the email part) into the text box and then clicking "Add key"

  4. katmerlin

    Renaming to id_rsa2 (aka removing the '.pub') got bitbucket to accept the key. I still have no idea why Bitbucket wouldn't accept the key copy pasted in, but, hey, whatever works.

  5. Sietse Brouwer
    • changed status to open

    Removing the '.pub' extension worked for me, too. If Bitbucket is rejecting key files based on the filename's extension, I would say that that counts as a bug.

  6. Dylan Etkin

    We have just rolled out an enhancement that lets you add labels to your SSH keys.

    As part of this effort and in an attempt to simplify the workflow we have removed file upload for ssh keys. Instead we OS detect and provide a command that will help you put the key into your clipboard.



  7. Log in to comment