api-get command not working in pipeline

Issue #18335 resolved
Ashish Agarwal created an issue

I want to add support of zip in pipeline with following pipeline

clone:
  depth: 1
pipelines:
  default:
    - step:
        name: firebase deploy
        image: devillex/docker-firebase
        script: 
          - cd functions
          - npm install
          - firebase deploy --token $FIREBASE_TOKEN

  branches:
     master:
       - step:
           name: deploy to production
           image: fracarma/docker-salesforce
           deployment : production
           script:
            - apt-get update
            - apt-get install zip
            - rm -f resource/staticresources/*.resource
            - zip resource/staticresources/css.resource public/css
            - zip resource/staticresources/js.resource public/js
            - zip resource/staticresources/fontawesome.resource public/fontawesome
            - zip resource/staticresources/templates.resource public/templates
            - echo "deploying to production"
            - jsforce-deploy -u $SFDC_USERNAME -p $SFDC_PASS -D resource

But its just not working with attached error

Comments (2)

  1. aneita staff

    Hi @ashishsujaka,

    Thanks for reaching out. Can you please confirm that the Docker image you're using has apt-get installed? The error message seems to indicate that the Docker image doesn't have it available for use.

    Aneita

  2. aneita staff

    I'm going to close this ticket. Please feel free to reopen this ticket if it's something you're still having problems with.

  3. Log in to comment