Why has the built in text editor been removed when creating an issue??!!

Issue #18361 new
S I
created an issue

If it isn't broken - why change it??? I have just tried to list an issue in one of my repos along with images / screen shots within the text (as I often do) only to find now I cannot drag and drop the image, I have to press "Select files" and FIND the image EVERY TIME and SELECT IT! Why move backwards? I am a paying customer and have been using you guys forever .. seriously I will look at another provider this update you've made is STUPID!

Workaround: You can go to Avatar > Labs > Turn off "Atlassian Editor" Beta and the Text Edits will be back when creating issues. Apologies for this.

EDIT :

The above 'Workaround' line has been added to my original post by one of the BitBucket Staff - this has worked for me for now but just to make the steps crystal clear - Tap on your Profile Image (Lower Left of Screen) > Bitbucket Labs > Turn the Atlassian Editor beta off (and if you don't want to explain why then just copy and paste this URL);

https://bitbucket.org/site/master/issues/18361/why-has-the-built-in-text-editor-been

I think maybe they were trying to improve the editor but it has a bug - hope they will keep us informed when the bug has been resolved as I would be happy to test out an improved version (so long as it doesn't disappear :) )

Comments (15)

  1. S I reporter

    And ironically you still have the "Attach" option top right AFTER the Issue has been created (circled in Green) .. complete insanity.. this bar (circled in red) is now missing in the original issue creator field .. but also ironically it is still visible for people responding ..

    insane.png

    Here is where it used to be when posting an issue - but now has been removed by some genius minimalist UI guru no doubt ..

    insane2.png

  2. S I reporter

    Still not working for me either, I have cleared cache etc .. is driving me crazy! I have reverted to just leaving a . in Issue description and using the comment field (which still has the toolbar) to document the description - I sure do not want to do that forever..

    stillnotworking.png

    And you can see here that the toolbar has no issue displaying when I make a comment.

    toolbarincommentOK.png

  3. S I reporter

    For anyone still have issues with this I see that a staff member has edited my original post and added:

    Workaround: You can go to Avatar > Labs > Turn off "Atlassian Editor" Beta and the Text Edits will be back when creating issues. Apologies for this.

    This has worked for me for now but just to make the steps crystal clear - Tap on your Profile Image (Lower Left of Screen) > Bitbucket Labs > Turn the Atlassian Editor beta off (and if you don't want to explain why then just copy and paste this URL

    https://bitbucket.org/site/master/issues/18361/why-has-the-built-in-text-editor-been

    I think maybe they were trying to improve the editor but it has a bug - hope they will keep us informed when the bug has been resolved as I would be happy to test out an improved version (so long as it doesn't disappear :) )

  4. Log in to comment