1. Bitbucket
  2. Public Issue Tracker
  3. master

Issues

Issue #2092 resolved

No password due to OpenID-based registration

David Makogon
created an issue

I registered for bitbucket with an OpenID. I now have no ability to access my repository, as I have no password set up. I never received an email upon registration, and I've requested a password reset several times yet have not received any emails with a link to reset.

Please send me a link as soon as possible, as I'm unable to grab code from my newly-created repository (that a friend has already made a commit to).

Thanks!!!

Comments (5)

  1. Thomas Johansson
    • changed status to open

    It's not possible to create an account using OpenID without also setting a password.

    If it's an old account (several months), you should have received an email with a password in it. Have you checked your spam/junk folder?

  2. David Makogon reporter

    I just created the account 2 days ago. It might have shown me a password on screen, but I didn't write it down, thinking it would be emailed to me. Alas, no email. Can you please simply send me a reset to my email address on file? I've been getting issues emailed there with no problem, and the email address matches my OpenId.

    I'm kinda stuck at this point... :(

  3. David Makogon reporter

    One more thing: if security is the concern, you can always reset my password to something trivial and put it in my account's inbox. I can easily log into my account via OpenID. I just cant access my repositories.

    Thanks again...

  4. David Makogon reporter

    I solved the problem with the password reset link. Problem was that I had changed my email address to something different from that used when signing up. I changed it back to the original email address, then requested a reset link. That worked, and I successfully changed my password.

    This should probably be reported as a bug. I'll go ahead and do that.

  5. Log in to comment