POST working fine on one repo, not on another. (BB-1024)

Issue #2285 wontfix
Nev Delap
created an issue

Hi there.

I have this repository...


...which is just a bogus repo for testing setting up continuous integration, and if you look at it you'll see it is just lots of bogus commits for that purpose.

It is set up with a POST to when the repo changes and that works just great.

The real repository for which this continuous integration stuff that I'm doing is intended is this one...


It is set up to post to the same url. But that hasn't worked. I've also set up an Email service on that one. I've not got it to post or email me anything when it is pushed to.

A difference between these is that my account was a paid account until Atlassian took over. Maybe that gave me something extra. digimagic (Jason's) isn't a paid account.

I also deleted the POST service and had Jason add it, in case that made a difference. It didn't, but I am admin on both so that was just a stab in the dark.

I was pushing to the test repo and real repo using my account, 'nevdelap'.

Aside from that I can't think of what would be different between the two.

Thanks in advance,


Comments (21)

  1. Nev Delap reporter


    I made a new repo, pushed the content of the repo that doesn't work into it, configured the POST services the same, and the new one works. So the only difference is that one is in nevdelap and the other is in digimagic.

    POST Works: Doesn't Work:

    I will get digimagic to log in and ask that you look at this problem since it's a private repo in his account.

    So I just have one question. Are the services only supposed to work on paid accounts?


  2. Brodie Rao

    Services should work on all accounts.

    We've been working on improving the reliability of services over the past couple of weeks. We still have some remaining issues to work out with asynchronous jobs not always getting executed properly.

  3. Nev Delap reporter

    Looks like for the last 12 hours or so it has been working fine. I'll set it to resolved if for a couple more days it is consistently working. Thanks.

  4. Nev Delap reporter

    Hi Brodie,

    Doesn't seem to be working now. I did a push maybe 15 minutes ago. After 5 minutes I stripped it and pushed it again. Neither posted.

    The last one that posted was at Tue Dec 21 00:37:01 2010 EST. Don't know if anyone pushed anything in between then and the ones I've just tried.

  5. Nev Delap reporter


    This was working fine for the last couple of months, up until recently, maybe about a week and half ago. The POST service is not visiting my URL again. There are two set up and neither is working.

    We've been pushing all week as normal, and I did three test pushes and the url wasn't visited.


  6. Log in to comment