remote: abort: abandoned transaction found - run hg recover!

Issue #2368 resolved
Ammler created an issue

Repo: redmine/redmine

Hello, I tried to strip some branches out of the repo, which resulted on a Error on last(!) strip I run. :-)

since then, I am not able to push anymore to the repo, I would like to keep the repo because it has forks based on it or followers.

Is it possible to fix this?

BTW:: the style of this form seems broken, I don't see what I type. (Firefox 3.6.12)

Greets Ammler

Comments (4)

  1. Brodie Rao

    It looks like your repository had an abandoned hg transaction. I've rolled back the transaction, and you should be able to push to it now.

    As for what caused the issue in the first place, I'm still looking into it. It may be related to stripping the repository, but just to confirm: did you notice any issues with pushing prior to using the strip form?

    Regarding the form issue in Firefox, if you could file another issue for that, that would be great.

  2. Ammler reporter

    I am a bit confused, shall I report issues with the repo here or per email? It would need another "hg recover"

    Else I remove the repo and recreate but will I lose followers/forks then?

  3. Log in to comment