Issue #3038 open

Customize Issue Statuses (BB-2642)

created an issue

Hi There, would it be possible that you can provide us with the functionality to customize or add new statuses for issues? We are in need to have the status "UAT" and "Live"?



Comments (82)

  1. DurhamG

    Bumped. In particular I need a 'Confirm fix' status. So the developer checks in a fix, marks it 'Confirm', then another developer (or tester) confirms the fix works and marks the bug Resolved. TFS has this but they call it Active/Resolved/Closed.

  2. John Furukawa

    Bumped also for the general ability to add states.

    I was going to file specifically for just the addition of "Verified" - representing the state that follows testing ... in my experience "Resolved" indicates that the developer has tried to fixed an issue but the probability of it being actually resolved is far less than 100% the first time around. So the Resolved state (or whatever dev marks a bug after applying a fix attempt) is best viewed as a queue of work for the testers. The output of testing needs a state.

    The tracker is really unusable process wise until there is some reasonable capability here. Since my team started a project on bitbucket, we're giving it a go, and I'm using a milestone (verified fixed) and assignment to "nobody" as a temporary solve.

  3. aaronaverill

    You absolutely must support at least one more state to indicate a bug has been verified as fixed. Hello ?!? Never heard of a QA process ?

    I would propose the following *simple* changes:

    1. Add a new state "closed"
    2. Change the query for the "Open" button to be ("new" || "open" || "resolved")

    This should literally be an afternoon of work, and require no database alter.

    If a project wants to use the current system, someone fixing a bug marks it as "closed"

    If a project wants to use a proper QA process, someone fixing a bug marks it as "resolved" and the QA person marks it as "closed".

    A side effect is that for existing projects clicking the "Open" button will see all the resolved (fixed) bugs. I propose a simple enhancement if you are worred about this:

    Add a one-time only banner above the issue list while viewing "open" which says:

    Issues marked as "resolved" will now be considered open until marked "closed". Would you like to mark all resolved issues closed? [yes] [no]

    When [yes] or [no] is clicked, the banner text is hidden forever.

  4. ccanepa

    I wanted a 'RepoFixed' state that will serve two purposes:

    • users that hits a bug can see at a glance if switching to default head can help them
    • release manager knows which issues should close after the next release is done

    After seeing other people entries in this threads, seems that long term the better would be to have customizable issue statuses.

  5. Anonymous

    Another +1 from me!

    At the very least, we could do with "Needs Testing". But being able to add custom statuses would be better.

  6. Anonymous

    Oops! Was just messing! However, since it's a year old "New" doesn't seem appropriate anymore anyway!

  7. Jens Claes

    Another +1 from me... Even just adding "Testing Needed" would be very nice! But if possible custom workflow would be very nice (similar to the components field where you can add your own workflow status...

  8. PDI Builds

    I could use this, as well. Right now we've re-purposed the "wontfix" status to indicate verified/certified (once QA has tested the change). I kind of feel that "wontfix" and "invalid" have somewhat overlapping meanings anyway.

    We joking say, "we won't have to fix that again"... but a more explicit status for this would be nice.

  9. Justen Stepka

    Official update:

    At this time we do not have an estimate for when this feature will be implemented. Our focus for the short to medium term, will be to provide SSO and better user management with our OnDemand JIRA and Confluence products. I would estimate that the SSO integration and bi-directional oAuth integration between Bitbucket / JIRA / Confluence / Bamboo will take us well into 2014, at which time we will re-evaluate this decision.

    Cheers, Justen -- Bitbucket product manager

  10. Daniel Gibson

    The thing I miss most currently is an "in progress" status, so it's obvious that someone is already working on fixing the bug. A "ready for testing" status would also be nice, I guess.

    Of course having totally customizable states would be the best option.

  11. David Wood

    +1. This seems like basic functionality, especially for an issue tracker that has been around for a long time.

    Bitbucket team, please reconsider this.

  12. Denis Kuzmin (reg)

    Please set as in Google Code,

    e.g. currently is very uncomfortable with the single status 'Open', need a:

          ---- 'Accepted' or 'Verified' or 'Confirmed'
    Open ----- 'Started' or 'In progress' etc.
  13. JoelEsli

    +1 At present, there is no workflow, the statuses are just tags and an issue can be tagged with any tag at any time. Would be cool to be able to customize these tags.

  14. Denis Kuzmin (reg)

    generally, the labels(like on github) is more convenient

    Issue #5356 is more priority for me, i also voted there... however, please to make ANY variant (omg, issue started 2011-09-21)

    currently i also tested the Milestone field instead of the original purpose for additional statuses, but...

    well., continue to use private tracker for basic workflow :(

    this or similar features really does not intersect with Jira, and not so difficult for implementation, so... why is so long need to think о_О

  15. Daniel Gibson

    Indeed. Atlassian obviously has no interest into making bitbucket issues less crappy, because they hope you'll buy JIRA instead.
    JIRA seems total overkill if you just want a slightly less crappy issue tracker (and free alternatives like gitlab exist), but good luck with that, anyway.

  16. Brett Bagenstose

    We have Jira and it's not the solution we want. we want to add custom statuses OR simply "ready to test"

    otherwise developers close out bugs without QA teams confirming

  17. Denis Kuzmin (reg)

    bitbucket is dead...

    For Atlassian this product has never been as primary or even as an important element for their business. It was as test to promotion their primary services like Jira etc. But, I'm afraid that it is the end (it can be as with google code or similar, later /if their management does not select another way)

    All new features are stuck in the past as and current task :( just look on 2011-09-21 line above for this (or as I wrote above about labels), and list of other serious improvements

    Currently it's uncomfortable at all: current bugtracker, Wiki, files for releases etc. (in comparing with existing free services of course). However yes, we have a free unlimited private repos - but and for this, is also ... in the past. You know, who I mean, and as for github it's also as primary product ~ index of vitality :)

    well, for this way, currently, we have the good service as online public & private arhives of available repositories at least...

    sorrowfully :)

  18. Log in to comment