1. Bitbucket Website
  2. Public Issue Tracker
  3. master

Issues

Issue #3080 resolved

Importer returns "no repository exists" error message instead of "requires auth" (BB-2823)

Eric Duncan
created an issue

Page: https://bitbucket.org/repo/import

When attemping to import an SVN repository, it seems the only valid URLs must be prefixed with http or https.

Per SVN documentation, urls starting with svn: is also a valid prefix that indicates to connect on a different port (port 3690, fyi).

My current repository is located on such an url, and therefore I can't import it.

Thank you!

Comments (14)

  1. Dylan Etkin

    Hi Eric,

    I know that not many folks still host SVN repositories via that protocol but I am pretty sure our importer will accept that URL format and perform the import.

    Are you running into errors using this?

    Cheers,

    Dylan

  2. Eric Duncan reporter
    • changed status to new

    Thanks Dylan!

    Yes, I should have been more clear. The issue is in the validation on the Import Repository page when creating a new repository (https://bitbucket.org/repo/import), specifically for the URL field. It gives the validation error:

    No repository exists at that URL.

    ...when you tab off of the URL field.

    The url I am using is: (the url goes away tomorrow, so I don't mind sharing it - it's not anonymous)

    svn:/ /svn.mixxdigital.com/eric.duncan

    (^-note: due to the formatting engine for this ticket system, I had to insert a space between the two forward slashes, else it gets filtered out).

    I copy and paste the url from my Repo Browser, but yet I get the validation error "No Repository exists at that url".

    OT: I attempted to Edit the original ticket to add an attachment, but this Ajax-style editing doesn't seem to allow me to attach a file.

    I tried to attach the file to this comment, but it doesn't seem to let me Update the issue if I specify an attachment. If I remove the attachment, I was able to click Update.

  3. Mehmet Catalbas
    • changed status to open

    Hi Eric,

    Since that repository requires authorization, did you try clicking "Requires authorization" checkbox and entering your username and password? What happens then?

    Looks like we're returning "No Repository exists at that url" message even though the repository exists but requires authorization, and that is obviously a bug.

  4. Eric Duncan reporter

    mehmet: Yep, I tried checking the checkbox. As soon as the URL textfield looses focus, it presents the validation error message - even before I can type the username/password (which doesn't allow me to continue).

    Thanks!

  5. Mehmet Catalbas

    Erik: Even though the URL field displays a validation error message, you should still be able to enter your username/password and submit the form?

    But as I said, we'll definitely fix this issue and display sensible error messages.

  6. Eric Duncan reporter

    OMG, you are right! it still works! :) It's importing as we speak!

    Ok, so this entire ticket is just about the client-side/ajax validation of the url.

    -E

  7. Log in to comment