1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues


Issue #3135 invalid

405 error when using https

created an issue

I'm trying to clone my repository, but I get a 405 error.

bfawcett@unicron:~/Desktop/Atlassian/test-code$ git clone https://bfawcett@bitbucket.org/bfawcett/clock.git Initialized empty Git repository in /home/bfawcett/Desktop/Atlassian/test-code/clock/.git/ Password: fatal: https://bfawcett@bitbucket.org/bfawcett/clock.git/info/refs download error - The requested URL returned error: 405

Comments (14)

  1. bfawcett reporter

    (Reply via br...@sevone.com):

    I was trying to use the https url immediately after creating the repository. Just tried it again and didn't get the error. How long do I normally have to wait after creating the repository before cloning with https?

  2. David Chambers

    You shouldn't need to wait. What probably happened in this case is that the front end which handled your clone request hadn't yet learnt of the repository's existence. There's currently a small window in which this can happen; we're hoping to close it!

  3. Dylan Etkin

    Hi worldsayshi,

    Can you open a support request by emailing support@bitbucket.org?

    When doing so can you please provide the verbose output of the git clone command?



  4. Anonymous

    This is an commun problem? I'm having the same problem since a days ago, did you find any solution?

  5. Per Fredelius

    For me the problem was local (only occurs on computers at campus), probably some firewall issue. Possiby something to do with http servers running on the same system (That is a statement on vague grounds. I'm not that into network configuration). Since I can still use ssh from campus I'm content. Now I know it will work for others.

  6. Kevin Meixner

    I am having the same problem.

    The Error I get is as follows:

    error: The requested URL returned error: 405 while accessing http://kevin_slyce@bitbucket.org/slyce/specialized-c-optimized-server-code.git/info/refs?service=git-receive-pack/info/refs&service=git-receive-pack fatal: HTTP request failed

    The SourceTree version I have is:

    SourceTree version: Copyright Atlassian 2012-2013. All Rights Reserved. Version

    When I check for updates via the "Check for Updates" tool included with SourceTree it says "Your software is up to date"

    Note: I was unable to install source tree via the default installer on Windows 7, it kept giving me an HTTP error, so I had to install it via a direct link to the executable here and upgrade it via the "Check for Upgrades" tool included with it:


  7. Kevin Meixner

    Okay, so now I got an email:

    We noticed that you tried to push to https://bitbucket.org/slyce/specialized-c-optimized-server-code, but failed. This is because the owner of the repo has exceeded their plan limit.

    To fix this issue and restore write access to the repo, either [NAME REDACTED]'s account plan will need to be upgraded, or some of their collaborators will need to be removed.

    -- It would be helpful if instead of giving some convoluted 405 HTTP error you just returned an error stating what you send in the email in the first place which is obvious since it is in clear plain English.

  8. Log in to comment