Issue #3201 resolved

Can't upload public ssh-key (BB-3096)

Dušan Lago
created an issue

I'm trying to upload my ssh publick key, but always with the same error message "Invalid file type".

I've followed bb ssh tutorial, generated new keys, changed chmod... {{{ [dudko@archy ~]$ ssh -V OpenSSH_5.9p1, OpenSSL 1.0.0e 6 Sep 2011 }}}

Any ideas are welcome.

Comments (13)

  1. Kjell Hedström
    • changed status to open

    I'm having the same problem. When googling it seems there are a few people who have experienced this,.. but all of them say that "after a few days, it started working".

    Anyone who actually know how to resolve this?

  2. Nikhil Bhardwaj
    • changed status to open

    I have the same problem, it seems impossible for me to add my key as it just doesn't upload keys.

    Awesome service this is. I can't understand why somebody isn't looking into this.

  3. Dylan Etkin

    Hi All,

    Sorry about the problem you are facing here.

    We were under the impression that we had fixed the issues folks were having with this problem but apparently thats not the case.

    If any of you who have commented could provide more information that would be very helpful.

    Where did you generate your SSH key, windows, linux, mac? Have you tried both the upload key and copying pasting the key? Have you uploaded this key for any other Bitbucket accounts you may have (we only allow one unique key to be paired with one account)?

    We will look into this issue but any information you can provide will help us get the bottom of things quicker.



  4. Tatsuya Ono

    Although I am not sure that other people was struggling with the same reason, I share my experience.

    In my case, I was simply stuck in the UI. I thought the textbox was the key name for manage ment and 'Choose Key' button was for fileupload form. Thus the step I thought was...

    1. Input key name to the textbox
    2. Upload public key
    3. Click "Add key" button.

    I noticed that it was wrong after googled and read Dylan's message above. Maybe I am just careless and silly, though, I think that there are some misleading points.

    • I don't think that everyone notices the button text change from "Choose key" to "Upload key"
    • To require clicking a same button twice for completing something is not well known UI pattern
    • Github lets you to manage SSH keys with naming. The current UI may make some people, especially who use github, misunderstand.
  5. Derek Harrington

    Everything worked fine for me on my mac when i set it up, but when I went to add a second key from another computer (a Windows Computer), I had to remove the ".pub" extension and it worked.

  6. Dylan Etkin

    We have just rolled out an enhancement that lets you add labels to your SSH keys.

    As part of this effort and in an attempt to simplify the workflow we have removed file upload for ssh keys. Instead we OS detect and provide a command that will help you put the key into your clipboard.



  7. Vitor Lobao Fernandes

    Got this same damn problem today.. found this thread (which helped a little) BUT I solved my problem and here's what I did: Used puttygen to generate the key: Option: SSH2-RSA Number of bits: 2048 (Default from puttygen was 1024, which was causing the problem) Copied it directly from the puttygen screen and it worked.

  8. Log in to comment