1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues

Issues

Issue #3290 closed

Problem with Jenkins services integration (BB-3063)

itanywhere
created an issue

Hello. I configured Jenkins service integration on my repository which is https://bitbucket.org/itanywhere/jcf-iam. my jenkins endpoint url is https://haibane.ci.cloudbees.com and project name is JCF-IAM . I just typed full url with token on browser then build was successfully started. so Jenkins has no problem. but bitbucket useing service integration never has made my jenkins build started. so I guess Jenkins Service integration has a problem. please look at this problem. and reply me. thanks for reading this.

Best regards

Comments (21)

  1. Dylan Etkin

    Hi,

    We recently tested the Jenkins service and found it working.

    Are you certain that you saved all the parameters that the Jenkins service takes? Have you tried adding a simple POST service to your repository (just to confirm that your services are firing)? There are a number of sites out there that will allow you to POST data and inspect the payload.

    If further investigation of the configuration of the service leaves it still not working I think it woud be best to handle this issue through support@bitbucket.org.

    Cheers,

    Dylan

  2. CurveTips

    This is failing for us as well. Looking at the apache logs for our Jenkins instance bitbucket is never sending the build trigger to Jenkins, even though it is configured correctly on the bitbucket site as far as I can see.

  3. Ryan Bichon

    It is not working for me as well. I setup a user account with full access specifically for bitbucket. I have tried:

    http://bbuser:<api key>@jenkins.myserver.com/

    http://bbuser:<password>@jenkins.myserver.com/

    I also setup the authentication token to no avail. I am not sure if this is a bitbucket issue or not. When I go to http://jenkins.myserver.com/job/MyJob/build?token=<TOKEN_NAME> in my browser, I get sent back to a login screen. As I understand it, this should kick off a build without the need to login.

    Any ideas?

  4. Log in to comment