1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues

Issues

Issue #3451 closed

Source tarball corrupt (prevents deployment to AppHarbor) (BB-3353)

Andrew Harcourt
created an issue

Hi,

I'm having trouble with deploying a project to AppHarbor as the tarball that the AppHarbor guys are fetching from BitBucket is corrupt.

It looks like it's something specific to a particular repository (my uglybugger.org project) as my others seem to be working fine. It's verifiable outside of AppHarbor, too - just downloading it from the "get source" menu fetches a broken archive.

For an example of the broken tarball, try opening this one: https://bitbucket.org/uglybugger/uglybugger.org/get/245aa0bc8522.tar.bz2

I've tried deleting the repository, re-creating it then pushing all my changes back but I get the same result.

Comments (3)

  1. Andrew Harcourt reporter

    UPDATE: It's a problem with Unicode characters in filenames. If the head of the repository contains any filename with Unicode characters, the download just bombs out (presumably) whenever it reaches that file on BitBucket's filesystem.

  2. Log in to comment