Issue #3497 resolved
created an issue

i tried importing a repository from my web server to bitbucket, but the import freezes at 80%. i was going to just delete it, create a blank one with the same name, and hg push to the new blank repo. whenever i click on the importing repo, it starts the progress bar over, and hangs at 80%. i cant find a way to delete the repo, since the progress meter blocks the controls. i have tried shutting down the web server to see if it would realize that there is nothing there, but it still goes from 0 to 80, then stops. its not an auth issue, since the logs indicate a successfull login. however, my bitbucket username is fizyplankton, the owner of the repo im uploading is alex (me), and the username i chose to use to authenticate the import was 1127, and the logs say {{{


[Thu Jan 12 21:39:06 2012] [error] [client] user fizyplankton not found: /hg/robot/ }}} /hg/robot is the location of the repo on my server. Does anyone know how to force it to stop, or would it be possible for a bitbucket site admin to delete my repo "robot"? thanks in advance

Comments (5)

  1. Erik van Zijst

    It's not clear to me what repo you were importing into. Repo fizyplankton/alex doesn't seem to exist.

    Could you please email for things like this? To solve this, we might need more information that you might not want to share on this public issue tracker.

    Regards, Erik

  2. fizyplankton reporter

    sorry if i didnt clarify. the bitbucket repo is "". it had priorly been "". the apache one (74.166...) needed a username and pass to log in. the user was 1127. the pass is my own business. the other user that apache would accept was alex. alex (me) is also the owner of the repo. heres the apache robot hgrc

    allow_push = alex, 1127
    push_ssl = false
    description = milton robotics repository
    username = alex

    the [ui]username on the central repo controlled what apache would display as the owner. i abandoned apache and tried to import it into bitbucket with

    import server url =
    import username = 1127
    import password = ********

    . thats when it hung. after a few hours, it said "import failed" or something along those lines, and deleted itself. i created a blank bitbucket repo called robot, and pushed from my comp to bitbucket. now, it works, but the bug is still somewhere in the code. ill be happy to work with you all to fix it. if theres one thing to take away from this post, here it is


    delete it and my reign of internet trolling shall strike down upon thee with great vengeance. and also, i do not mind sharing any details here, other than my (fizyplankton)'s password, and the 2 apache passwords (if i share any of the passwords, the code becomes publicly availible, making it "commercial, of-the-shelf", meaning it is a violation of the rules to claim any rights to our code, and we risk disqualification)

  3. Erik van Zijst

    Good to hear you managed to work around it by pushing it manually.

    I'd like to have a closer look, but that'll require the link that was in the email that was sent out after it failed (for that link contains the ID of the background job on our end).

  4. Log in to comment