Issue #3583 duplicate

Git: Branch list not showing up

Roshan Amadoru
created an issue

I cannot switch branch inside bitbucket like it's mentioned in (step 9). Can you please explain the reason for this? It would be fancy to have this functionality working.

Comments (15)

  1. Roshan Amadoru reporter
    • removed component

    Actually, this issue I've originally reported is invalid because you can see the branch list from the UI itself. It's just you will not simply notice it the first time if you are new to bitbucket. I have faced this very same confusion so this original issue report.

    To see the branch list, click the gray color horizontal line just below project name in the overview section. (This line is clickable). Then you will be able to see the place where you can view other branches.

    This is a flaw in the UI design because that clickable section is not obvious at a first look. Regardless, hope this reply helps you.

  2. The iPlatform

    Hi Roshan, thanks for getting back to me. I can see the 'branches' dropdown menu, however I can only see the master branch in the dropdown, and not the second one I created. I know this branch exists as I have tested it on my machine, I can switch between them and commit/push to them, but in the bitbucket UI it always show's i've commited to master. Not sure if this is something I am doing.


  3. Anonymous

    Sure no problem. :) Just out of curiosity, did you push the new branch to the remote github repo (in this case bitbucket repo)? Unless you explicitly push the new branch to the remote, remote will not see your new branch.

    You have to run the command like below, where new_branch is the name of your new branch that needs to be pushed.

    git push origin new_branch
  4. Hugo Villero

    Hi Please fix that UI I was expending almost 3 hours looking for the way to see the branches in the UI until I found this issue,

    Thank you,

    Hugo Villero

  5. Arangarx

    I'm getting this issue as well. My branch lists don't show the other branches I've created aside from master.

    Edit: It looks like you have to kill your session entirely to see the new branches. (close the tab)

  6. Steve Muskiewicz

    We are seeing this issue as well on Safari. Closing the browser tab doesn't appear to fix it, you actually need to quit the browser entirely and restart. Have not been able to reproduce on Chrome or Firefox (We are logging in to Bitbucket via Google if that helps)

  7. Frederic Mohr

    I had the same issues, the branch was listed on the "Branches" page, and the overview showed 2 branches instead of just one (the master), but when I clicked on the dropdown on either the "Overview" or the "Source" page, it only showed the master.

    For me, logout and login worked. Now both branches are shown. Hope it helps...

  8. Log in to comment