1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues

Issues

Issue #3672 resolved

SSH key problem on remote server

Pete Thompson
created an issue

This isn't a bug. I'm just not very adept with SSH - I've gone through your troubleshooting guides and I still can't resolve the issue.

I'm attempting to clone a git repository in a remote server, and I'm wondering if someone can help me troubleshoot. I've added my localhost rsa key to the remote host and to my bitbucket profile. when i run ssh git@bitbucket.org from my local machine it works fine. Below is the verbose output from the remote host when I run ssh -v git@bitbucket.org on the web server:

{{{

!python

OpenSSH_4.3p2, OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008 debug1: Reading configuration data /etc/ssh/ssh_config debug1: Applying options for debug1: Connecting to bitbucket.org [207.223.240.181] port 22. debug1: Connection established. debug1: permanently_set_uid: 0/0 debug1: identity file /root/.ssh/identity type -1 debug1: identity file /root/.ssh/id_rsa type -1 debug1: identity file /root/.ssh/id_dsa type -1 debug1: loaded 3 keys debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3 debug1: match: OpenSSH_5.3 pat OpenSSH debug1: Enabling compatibility mode for protocol 2.0 debug1: Local version string SSH-2.0-OpenSSH_4.3 debug1: SSH2_MSG_KEXINIT sent debug1: SSH2_MSG_KEXINIT received debug1: kex: server->client aes128-ctr hmac-md5 none debug1: kex: client->server aes128-ctr hmac-md5 none debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP debug1: SSH2_MSG_KEX_DH_GEX_INIT sent debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY debug1: Host 'bitbucket.org' is known and matches the RSA host key. debug1: Found key in /root/.ssh/known_hosts:3 debug1: ssh_rsa_verify: signature correct debug1: SSH2_MSG_NEWKEYS sent debug1: expecting SSH2_MSG_NEWKEYS debug1: SSH2_MSG_NEWKEYS received debug1: SSH2_MSG_SERVICE_REQUEST sent debug1: SSH2_MSG_SERVICE_ACCEPT received debug1: Authentications that can continue: publickey debug1: Next authentication method: publickey debug1: Trying private key: /root/.ssh/identity debug1: Trying private key: /root/.ssh/id_rsa debug1: Trying private key: /root/.ssh/id_dsa debug1: No more authentication methods to try. Permission denied (publickey).

}}}

Any help with this would be greatly appreciated! Regards, Pete Thompson

Comments (3)

  1. tutorials account

    Peter, I'm sorry you are having trouble. Let me see if I can help. If I understand you correctly the following things are true:

    • You have two machines you are cloning to using ssh. One is a local machine and one is a remote server.
    • You created an identity on your local machine.
    • You added the public key to the bitbucket account.
    • You copied your identity (public and private) to your account on the remote web server
    • You can clone using ssh to your local machine.
    • You cannot clone to your remote web server using ssh.

    Looking at the output from the command, when you attempt to clone from bitbucket to the remote machine, the SSH cannot verify your identity on the remote machine.

    Most people recommend if you are going to access an account from two separate machines, that you create a unique identity on each machine. So, I would recommend you remove any keys you copied to your remote machine. Then, create a default identity on the remote machine. Add its public key to your bitbucket profile. (Your account will show two keys at this point.) Then try the clone again.

    Let me know if this does not solve your issue.

    Cheers,

    Mary

  2. Log in to comment