Issues

Issue #3770 resolved

Commit messages aren't always updating issues (BB-3832)

v2k
created an issue

commits containing: {{{ ref #1 fix #1 }}}

for example; are not updating and/or linking to the issue 1.

it worked in my public repo, but I cannot get it to work in any of my private repos.

Comments (12)

  1. Nicolas Venegas

    Hi

    I already responded to you about this issue via our support system, however, in case anyone else is experiencing this problem, I'll copy my response below:

    > I just tested this on a local machine and on bitbucket.org with a
    > private mercurial repo (with a private issue tracker) and a public
    > mercurial repo (with a public issue tracker).
    >
    > I was able to get a simple test of a commit with the message including
    > "(closes #1)" to close issue #1.
    >
    > Are you sure the Issue service is enabled for the repos you are having
    > problems with?
    > http://confluence.atlassian.com/display/BITBUCKET/Setting+Up+the+Bitbucket+Issues+Service
    

    Regards

    Nicolas

    Edit: The code block formatting of my email's contents is incorrectly changing what should read "(closes #1)" to "(closes <left-angle-bracket><left-angle-bracket>issue 1<right-angle-bracket><right-angle-bracket>)".

  2. Nicolas Venegas
    • changed status to new

    Some examples of this not working (copied from the support request):

    fix - didnt work
    ref - didnt work
    references - worked once today
    fixes - worked once today
    refs - worked once today
    
  3. Marcos BL

    +1

    Issues tracker doesn't seem to work for me. I have a private repo with Issues enabled, i created an issue using the web interface and made a lil change locally + commit + push with a "fixes #1" message.

    I can see the commit in the web interface, and it links to the issue, but the issue have not been closed, nor i see anything changed on it. Already tried all the different words at https://confluence.atlassian.com/display/BITBUCKET/Setting+Up+the+Bitbucket+Issues+Service

  4. Log in to comment