1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues

Issues

Issue #3911 resolved

hg clone always fails

Brian Ushman
created an issue

Hello, whenever I run hg clone, after a while i get the following message: abort: stream ended unexpectedly (got xxxxx bytes, expected xxxxxxxxx)

I tried this several times without success. Is there a cap or limit as to how much data can be download from a repository in one session? I'm not sure what else I can try.

Thanks for the help!

Comments (4)

  1. Brian Nguyen

    Hi Brian,

    We have seen this error occur for large repositories that are cloned over HTTPS. We are actively looking into the problem but we haven't found a solution just yet. The workaround at the moment is to use SSH, this page provides instructions on how to set this up (http://confluence.atlassian.com/x/noAkE).

    If your problem is not related to HTTPS, could you send an email to support@bitbucket.org and we'll help you out further.

    Cheers, Brian

  2. pattybobatty

    Hi, we have been experiencing this same issue repeatedly lately and it seems we can no longer successfully create new clones of our repository. Our tree has grown recently and is not 1.5GB, which does not seem unreasonably large.

  3. Log in to comment