1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues

Issues

Issue #4032 resolved

Permission denied (publickey).

Mike Simoens
created an issue

Hi,

When i run:

{{{ hg clone ssh://hg@bitbucket.org/lakin.wecker/freeandeasytraveler.com fne }}}

I get: {{{ remote: Permission denied (publickey). abort: no suitable response from remote hg! }}}

This worked two days ago without issue.

Since then i've upgraded from ubuntu 10.04 to xubuntu 12.04

I have created new sshe keys and the error persists. Any suggestions would be welcome.

M.

Comments (5)

  1. Dylan Etkin

    Hi Mike,

    I would rather run this through support@bitbucket.org since it is a personal issue and we may want to exchange some private information.

    That said, I would try to run your command with the -v flag. It is most likely the case that mercurial is not picking up your private key from your .ssh directory.

    If you can ssh into some other box that already knows about your public key then this would confirm that your system is correctly finding the key.

    You may also try specifying your ssh config directly to hg http://machghelp.jasonfharris.com/kb/connections/multiple-ssh-keys-for-multiple-mercurial-repositories

    Cheers,

    Dylan

  2. Log in to comment