1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues


Issue #412 resolved

Ability to change username with OpenID

Lee McFadden
created an issue

It's currently not possible to change/choose your username when using OpenID. I initially signed up with OpenID which set my username as Splee (note the capital letter). All the URL's for my bitbucket repositories are now case sensitive which isn't ideal.

Is there a way to change my username so it no longer has the capital letter?

Comments (18)

  1. Lee McFadden reporter

    Apologies, the above comment was from me but I neglected to sign in. To reiterate, please change my user name to lower case 'splee'.

    Thanks in advance =)

  2. Lee McFadden reporter
    • changed status to new


    I thought this was resolved but apparently not. I haven't had to push anything to my repositories since this change but I get the following output when using SSH:

    pushing to ssh:bb/splee/languagelabapi searching for changes remote: adding changesets remote: adding manifests remote: adding file changes remote: added 1 changesets with 2 changes to 2 files remote: error: pretxnchangegroup.bb_perm hook failed: Can't find your username. remote: transaction abort! remote: rollback completed remote: abort: Can't find your username. abort: unexpected response: empty string

    I also tried to push to HTTPS but since I signed up with OpenID it doesn't seem to like doing that:

    pushing to https://splee@bitbucket.org/splee/languagelabapi/ searching for changes http authorization required realm: Bitbucket.org HTTP user: splee password: abort: authorization failed

    Any Ideas?

  3. Jesper Noehr
    • changed status to open


    For the first error (ssh), can you try to re-add your SSH key?

    For the second (http), you *can* use this even though you've signed up with OpenID -- when you signed up, we sent you a password in an email. This is the password you should use here. You may of course change this (you should.)

    If you haven't gotten this email, or you don't remember your password, let me know, and I'll update it for you.

  4. Lee McFadden reporter

    I've re-added my SSH key and I still get the same error.

    As for the HTTPS version, I requested a new password and then changed it - this allowed me to push to the HTTPS endpoint for the repository but I would prefer to continue using SSH if possible.

  5. Jesper Noehr


    Any chance you can join me on IRC? We're on irc.freenode.net, the channel is #bitbucket. I'd like to have you try while I'm watching the logfiles. This should help clear things up.

  6. Log in to comment