1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues

Issues

Issue #4123 invalid

fatal: The remote end hung up unexpectedly

On My Disk Team
created an issue

Hi, I'm encountering problem while cloning my repo:

remote: Counting objects: 112197, done. remote: Compressing objects: 100% (83359/83359), done. fatal: The remote end hung up unexpectedly23.48 MiB | 353 KiB/s
fatal: early EOF fatal: index-pack failed

It always hangs/up at cca 23-25 MB.

Is it a kind of limitation fo free plan?

Comments (42)

  1. Ellis Percival

    My problem was with ssh access. It's intermittent and affects more than one computer and repository. Been happening since a couple of days ago. I guess it's something different.

  2. Victor Figueroa

    I'm having the exact same issue and it's driving me nuts lol. I've created my rsa key a bunch of times thinking that I must've done something wrong but then I followed the steps at: https://confluence.atlassian.com/pages/viewpage.action?pageId=270827678 https://confluence.atlassian.com/display/BITBUCKET/Troubleshooting+SSH+Issues#TroubleshootingSSHIssues-Permissiondenied(publickey)orNosuitableresponsefromremote

    and all is good.

    For example, I've tested my key with: ssh -T git@bitbucket.org and I receive a successful response. Also, I ran ssh -v and received this: Host 'bitbucket.org' is known and matches the rsa host key. And this: Authentication succeeded (publickey). I even received this: Connection to bitbucket.org closed. Transferred: sent 2592, received 2904 bytes, in 0.1 seconds.Debug exit status 0.

    So it looks like everything's working. And even though I was able to clone the same repository on my first computer, I can't seem to clone it on my second computer even though I've added the RSA Key to my account like 5 times.

    Please, any help would be much appreciated.

  3. Victor Figueroa

    In case you're wondering about the exact error I'm getting, here it is: SSH: Could not resolve hostname bitbucket.org:pixelerium: Name or service not known fatal. The remote end hung up unexpectedly.

    Thanks, Victor

  4. Victor Figueroa

    This is the error I get when I try to clone the repository:

    Initialized empty Git repository in ???/???... .git/ Permission denied (publickey) Fatal: The remote end hung up unexpectedly.

    Just so you're aware I'm setting this up on a Linux box. I've confirmed my key has been added and used as you can see by the SSH -v added above.

    Thanks again, Victor

  5. Anonymous

    When I tried to clone , I am getting the following error fatal: early EOF

    fatal: The remote end hung up unexpectedly fatal: index-pack failed

  6. Liam Bilich

    Same issue (on windows 7, with git 1.9.4 msysgit.2) and it looks like it might be related to the repository which is 300mb in size. I'm trying ways to delete the master branch which is the largest, but cannot seem to do it because i cannot fetch any other branch as the remote goes through all the data in the repository and fails:

    remote: Counting objects: 1882, done. remote: Compressing objects: 100% (1042/1042), done. select: Not enough memory158/1882), 109.45 MiB | 74.00 KiB/s fatal: The remote end hung up unexpectedly fatal: early EOF fatal: index-pack failed

    Could this be caused by large binary files? i.e. perhaps something changed in BitBucket servers which processes repository files (objects) assuming them as text.

    i will trying checking out as-is, and see if it helps.

  7. Desarrollo NA

    Hi, maybe this can help anyone, I still have no idea why, but it worked fine for me. I was using this one:

    git clone git@bitbucket.org ....

    Changed it to this.

    git clone -v git@bitbucket.org...

  8. Liam Bilich

    Having been corresponding with Atlassian support, It looks like a network issue. I still yet to test it on another network, but will do so promptly and update this thread.

    In spite of the above, changing the post buffer to a larger number, seemed to help with getting a bit further in receiving the repository:

    git config http.postBuffer 524288000

    but it may as well be just an arbitrary outcome.

  9. Nicholas Ventimiglia

    Same. I cant download my repo. Using SourceTree.

    git -c diff.mnemonicprefix=false -c core.quotepath=false clone --recursive fatal: early EOF

    fatal: The remote end hung up unexpectedly fatal: index-pack failed

    Completed with errors, see above.

  10. SmitaSuvadarshini

    I am facing the following issue: fatal: The remote end hung up unexpectedly fatal: early EOF fatal: index-pack failed. I tried to clone with SSH over https.But while cloning through ssh it is saying could not read from repository.Kindly help me with this.

  11. Neil Kidd

    Hi,

    I'm getting the same issue with a fresh git clone. Each of ssh, https and download zip fail. For https cloning I get:

    remote: Counting objects: 67, done.
    remote: Compressing objects: 100% (61/61), done.
    error: RPC failed; result=18, HTTP code = 200
    fatal: The remote end hung up unexpectedly
    fatal: early EOF
    fatal: unpack-objects failed
    

    Any ideas?

    Thanks.

  12. Liam Bilich

    What resolved the issue for me was practically switching to a different network. in this sense, even restarting the router can help resolve the issue.

    It has to do with the round trip to bitbucket servers imho, and some kind of instability somewhere causes it to Hang.

  13. Paul Marvin

    Same here, can't clone a fresh copy of our main repo any longer...always returns this...

    fatal: The remote end hung up unexpectedly

    error: RPC failed; curl 52 Empty reply from server

    Completed with errors, see above.

  14. Mahesh Mhaske

    Damn it!!! Its actually a network issue, I don't how its behaving but switching network works. I was able to brows pages but git clone/pull failed. Wasted several hours to find it.

  15. avenzhu

    i have same question when clone. who can help us !!! Connection to bitbucket.org closed by remote host. 14.00 KiB/s fatal: The remote end hung up unexpectedly fatal: early EOF fatal: index-pack failed

  16. Jean Canazzi

    I had the problem with SSH for a few days now. My RSA key is correct, I can pull and push from an already cloned repository ; however if I try to clone my repository again from scratch, I get the error (exactly the same as reported by people above).

    The workaround for me was to switch to HTTPS, and suddenly "git clone" successfully completed.

  17. Michael Gane

    I had this issue on an already cloned repository.

    I got around it buy using:

    git fetch origin
    

    then i could checkout my branch and git pull successfully.

    git checkout master
    
    git pull
    
  18. Carlos Delfino

    I took a repository which is a clone of another existing in GitHub and did several tests, both on Bitbucket, and on GitHub and locally, and I'm only having this problem with bitbucke.

    At least so far.

    I have had problems with Vagrant which also complains about the connection being restarted which leads me to believe that the problem in my case is connected to the provider.

    The good thing is that Vagrant continues to download the point where it hears error, different from git.

  19. Log in to comment