1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues


Issue #4174 invalid

Clone/Pull on shared hosting with limited memory results in: "fatal: Out of memory, malloc failed" message (BB-4465)

created an issue


I've encountered this problem 3 times now in the last few months, so I am surprised that I haven't been able to find anything regarding this in your documentation.

In essence it seems the remote repo (Bitbucket) decides that it needs to be repacked and on a shared host with limited memory this results in the following messages:



remote: Counting objects: 9108, done. remote: Compressing objects: 100% (7317/7317), done. remote: Total 9108 (delta 2579), reused 7839 (delta 1518) Receiving objects: 100% (9108/9108), 120.75 MiB | 795 KiB/s, done. fatal: Out of memory, malloc failed (tried to allocate 177183921 bytes) fatal: index-pack failed }}}

I've found this on Stackoverflow:


And it seems to be spot on describing this problem. The proposed solution here is to change the config in the remote (Bitbucket) but as far as I can see this is not anything I can do??

Any suggestions? Thanks for your time!!

Comments (6)


    what a crap this service its a shit..

    the issue was complety invalidated..

    i have the same error:

    "fatal: Out of memory, malloc failed (tried to allocate 524288000 bytes)"

    to where we open a issue.. to a mail.. bitbucket does not have a ticket issue sistem where i manually load the tecnicall info!?

  2. Log in to comment