1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues

Issues

Issue #4570 resolved

remote: conq: invalid command syntax.

Maciej Maciaszek
created an issue

I'm getting remote: conq: invalid command syntax when I try to pusth to bitbucket mercurial repository.

I haven't got this before...

Mercurial Distributed SCM (version 2.3) (installed with HomeBrew on MacOS 1.8.1)

Comments (16)

  1. Isaac Turner

    I'm getting this too:

    % hg pull bits --debug
    running ssh hg@bitbucket.org '/home/turner/bin/hg -R isaacturner/repo serve --stdio'
    sending hello command
    sending between command
    remote: conq: invalid command syntax.
    abort: no suitable response from remote hg!
    
  2. Marcus Bertrand staff

    For those not running the latest Mercurial, please upgrade, it usually fixes unusual authentication issues. For the OP, please open a support request directly with all of your URL's and details and we'll get you sorted out. Support email is support@bitbucket.org

  3. Marcus Bertrand staff

    For those not running the latest Mercurial, please upgrade, it usually fixes unusual authentication issues. For the OP, please open a support request directly with all of your URL's and details and we'll get you sorted out. Support email is support@bitbucket.org

  4. Erik van Zijst staff

    Correct.

    Using --debug nicely reveals the command that your local hg process tries to execute on our servers. In Isaac's case, that is /home/turner/bin/hg which obviously does not exist on our end, leading to the "invalid command" error that you see printed.

  5. Robert Wallis

    Just +1, had the same problem, and in my ~/.hgrc [ui] remotecmd was specifically set because of another server having problems finding the executable in the path.

    So I resolved it by removing the remotecmd from my global .hgrc, thanks Erik

  6. Log in to comment