1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues

Issues

Issue #4867 wontfix

Need help cloning large repo.

Aneeta Kolhe
created an issue

We have a large repo(around 4GB) up on bitbucket using mercurial. When we try to clone it it gives an error files: 2985/6183 chunks (48.28%) transaction abort! rollback completed abort: stream ended unexpectedly (got 14630119 bytes, expected 15066920)

Till now we have tried quite a few times, and actually it gets stuck at the same place every time. These are these video files in with extension .ogv.

Any help is appreciated !!

Comments (5)

  1. Aneeta Kolhe reporter

    I forgot to mention. The way I created repo was using the online tool of bitbucket, importing an svn repo from beanstalk to mercurial bitbucket, which worked smoothly.

  2. Dylan Etkin

    Hi Aneeta,

    I am sorry you are having trouble cloning your repo, you may want to try over ssh.

    However, storing videos in our site is a violation of our terms of service. We are a source code hosting site and are not to be used for general storage.

    If your problems persist you can contact support@bitbucket.org. We can help you get your data but unless there is some compelling reason for storing video's it should not be happening.

    Cheers,

    Dylan

  3. Log in to comment