1. Bitbucket Website
  2. Public Issue Tracker
  3. master

Issues

Issue #4918 resolved

"Update a Group" Api Endpoint Does not update

Anthony Steiner
created an issue

I tried everything I could. I could not get my group to update. Update A Group Steps to reproduction (using Fiddler2)

  1. Set HTTP Method to PUT
  2. Set url to https://api.bitbucket.org/1.0/groups/steinerd/test-2/ (which is a valid group, also attempted the email for account name)
  3. Set the Authorization header to the base64 encoded username:password it expects
  4. Set Content-Length header to 0 (and also tested with the correct byte size of the request data, same result)
  5. Set Request body to name=New+Group+Test&permission=admin&auto_add=true (I also tried with %20 for spaces and no encoding, same results)

I know that PUT sends a 302 upon success by design... but for a handful of them it was forwarding off to the return URL but didn't actually change anything.

Comments (5)

  1. Anthony Steiner reporter

    Look at that, it's expecting JSON for the request payload and content-type in the request header. I can work with that on my API.

    This bug isn't a bug, the API documentation is just misleading. I'll post my findings in the comments... see if we can get it clarified over there.

    Thanks! Go ahead and write this issue off, it's working, the PUT it was expected was just not well documented, and I'll be sure to have that updated.

  2. Log in to comment