Issue #512 resolved

Push to patch queue repo fails

Igor Tkach
created an issue

Attempt to push to queue repo fails with the following error: {{{ abort: repository is unrelated }}} even though patch queue repo has no recorded changes.

After initial qclone patch queue repo in .hg/patches is empty as expected (tip is -1:000000000000). Then I pull from existing patch queue repo. Then I'm trying to push and getting this error. qpush also fails, although error looks different: {{{ itkach@itkach-desktop:~/mwlib-patches/.hg/patches$ cd ../.. hg qpush abort: patch not in series }}}

Comments (4)

  1. Igor Tkach reporter

    Yes, that's what I did.

    I successfully created a patch queue for mwlib few weeks ago, called it mwlib-patches. Then I qcloned mwlib-patches:

    hg qclone mwlib

    This cloned the main repo and the queue repo. I created a patch, commited it to queue repo and pushed (don't remember exactly if it was qpush at the main repo level or push from .hg/patches) - everything worked like a charm.

    Yesterday I committed another patch and tried to push again, and this time it failed as described. I created nwlib and mwlib-patches from scratch and tried again - same result.

  2. Jesper Noehr

    qpush does not push to the repository the same way that push does. qpush merely pushes a patch onto the stack, and has nothing to do with remote repositories.

    To push your changes, you can try:

    cd .hg/patches/
    hg push

    This should yield the correct results.

  3. Igor Tkach reporter

    Ah, yes, sorry - I'm not sure why I tried to do that with qpush, I usually know what it does :)

    I did try to push from .hg/patches before, but default push path was not set for some reason and I must have been pushing to a wrong URL ( instead of - this is a bit confusing since mwlib-patches looks like a queue repo through web interface, but acts as mwlib repo with hg clone and qclone trhough http)... I went again through all the steps and it worked now.

    Thanks for your patience and great work , bitbucket is awesome :)

  4. Log in to comment