Repo "tksoh/hgshelve" requires authorization although there are no changes to push

Issue #5600 invalid
Former user created an issue

See title. Maybe the problem is the same as in #4794. As far as I understand it, the Mercurial issue that could be reason for the problem ( is still not fixed, so maybe a manual fix of the hgshelve repo, similar to the one in #4794 is required?

Brodie, I assigned it to you because you solved #4794 and probably know whats going on here.

Comments (4)

  1. Anonymous

    Hi Marcus,

    its ok for me to close this as invalid. Presumably it is related to Mercurial phases, as in the other issue I opened a while ago (#4794). As the Mercurial community doesn't seem to attack the problem (see, I fully understand that I cannot expect Bitbucket to manually fix phases on our repos every time that problem occurs.

    Until phases are fixed in an upcoming version of Mercurial, I will stick to my workaround: Use an older Mercurial (1.8.1 works fine) that knows nothing about phases to push repos with subrepos.

    Best Regards

    Nik Schüler

  2. Log in to comment