1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues

Issues

Issue #5937 resolved

Repository strip operations may fail if the changsets being removed have comments from a Pull Request or a line-comment (BB-6715)

Marcus Bertrand [🌝]
staff created an issue

If a user has made a comment on a changeset on a pull request or directly on a line comment, a strip operation may fail. In this case, support can help strip the changeset, but the user will no longer have any access to the comments or pull requests that the changeset was present on.

Comments (11)

  1. vadmium

    I also recently had an issue stripping changesets, although slightly different to what is described here. The repository was at https://bitbucket.org/vadmium/pyrescene, however I have since deleted and re-forked this repository, and moved on. Background in case it is any use:

    • Originally had at least two heads, using test and py3 bookmarks to distinguish them
    • Created pull request for the test bookmark at https://bitbucket.org/Gfy/pyrescene/pull-request/4
    • Pushed a third head to repository, replacing test, intending push this to the pull request
    • Successfully stripped the out-of-date changes and head referenced by the original test bookmark
    • Saw that the pull request wouldn’t list any revisions after hitting the Edit button
    • Tried to strip changesets from the py3 head. I even tried removing the py3 bookmark and stripping the single changeset from the tip of the head, which was not part of any pull request and did not have any comments.
    • In all cases, the strip page indicated success, but the next page I would load had a message near the top saying the strip had failed, and the changesets were indeed still there
  2. Log in to comment