1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues


Issue #6018 invalid

Http 412 error when connecting to Bitbucket (BB-7267)

Mark Park
created an issue

When pushing to Bitbucket, some users may receive the following message:

error: The requested URL returned error: 412 while accessing https://sh45park@bitbucket.org/sh45park/android-news-player.git/info/refs
fatal: HTTP request failed

This error message is erroneous and actually should inform the user that they don't have a password set on their account.

Comments (24)

  1. Marcus Bertrand staff

    This situation can arise if the user has chosen to log in with the new log in from Google/GitHub feature and opted to skip setting a password for Bitbucket activities.

    If you plan on using https to work with Bitbucket, you'll need to set a Bitbucket specific password. This can be done from https://bitbucket.org/account/password/change/{user name}/.

    Alternatively, you can use SSH. We have a guide to configuring it here

  2. Luciano Panepucci

    I am a new user:

    • I created my bitbucket account using my github OAuth.
    • I created a new repo.
    • I followed the steps to import existing repo.
    • When I tried the push I received this error.

    I then went to bitbucket site:

    • Click the user menu
    • Manage account
    • Change password

    After setting/changing the password the same push command prompted me for my password.

  3. Jeffry Houser

    my problem is that the 'username;' in the URL is not my account, but the account of a client. It all worked great last week. Today I'm getting this error.

    Changing my password appeared to have no affect.

    If I follow these steps it works [once]:

    • Edit --> Preferences
    • Go to hosting providers,
    • delete the BitBucket account
    • Click Okay
    • Click Push [or pull]
    • Enter Username and Password [Leave store password unchecked]
    • It works
    • Click Push (or pull) again
    • See 412 Error

    It seems odd to me that it works the first time but no subsequent times.

    I'm on version 5.0.6 (build #2105); downloading now.

  4. Yves Schleich

    I really don't know how you have done the password changing. The solution to set a password unfortunately doesn't work for me. If I try setting a password I get asked to enter the old password but if I'm registered with Github I don't have an old one.

    Bildschirmfoto 2015-11-25 um 10.36.45.png

    UPDATE: Resetting the password and setting one did the job

  5. Zachary Davis

    This was closed on our internal issue tracker some time ago, with the following comment:

    A message is being sent when a 412 is thrown, however, git is not displaying it when using https. This is a git thing, not a Bitbucket thing.

    Message: "abort: this user account (%s) does not have a password configured - to use your account over HTTPS, it is necessary to have a password set."

  6. Log in to comment