Problem with password with non-ascii characters

Issue #6130 invalid
Troels Damgaard
created an issue


Just to let you know: There seems to be a problem in using passwords with non-ascii characters.

Just made an account and selected a password which included non-ascii characters (Danish special characters). When trying to push my local repository I got an "abort: authorization failed." I tried a few times to ensure that I typed correctly.

I suspected an encoding problem and changed my password to include only ascii-characters. This solved the problem.

System: WIndows 8 Hg version: 2.4.2 Shell: Powershell v. 3.0

Comments (1)

  1. Jonathan Mooring staff

    I was not able to reproduce this with a test repository. I changed my password to include several non-ASCII characters and then attempted a push over HTTPS, which succeeded. This may be related to your environment. If you continue to experience issues, please open a ticket at and we can further assist you there.

  2. Log in to comment