1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues

Issues

Issue #6363 resolved

timeouts

Claus Holm
created an issue

Since yeasterday (February the 13th) at around 2pm utc, I started to get strange timeouts. Please see attatched file.

Today, the 14th, the problem persists. Do you know what could be causing it?

Comments (14)

  1. Claus Holm reporter

    Now, at 11.30 am utc (feb. 14th) the problem suddenly seems to have gone away. (Fingers crossed...) But it would still be nice know, if something in your end have been broken in this time.

  2. Brian Miller

    Haven't been able to access the site at all since 2/12 using any machine on my home network (Verizon FIOS). Site always times out. Curl works from shell account located elsewhere, and site comes up normally when connected to work VPN.

    Sounds related? Is there a network or firewall issue here?

  3. Claus Holm reporter

    Ok, why does your status page not say anything about this? By the way, It is not solved yet.

    Today is friday the 15th, and I just got both timeouts and ugly errors a few minutes ago.

  4. Brian Nguyen
    • changed status to open

    Hi Claus,

    Apologies. I closed the issue since the problem that was causing our known stability issue was fixed. I hoped that it would solve your problem as well but clearly I was incorrect.

    To help us, get to the root of this problem could you provide us with some additional information?

    • Do the timeouts occur for you in the browser, or is it only affecting your builds?
    • What url are your builds connecting to?
    • Is this occurring on one repository or many?
    • Do you get timeouts on non-repository pages? i.e. your user profile or on the dashboard.

    Cheers, Brian

  5. Claus Holm reporter

    Good morning,

    It is only in builds. I use TeamCity, and here I see the errors reported. The url is https://cholm@bitbucket.org/slankedoktor/slankedoktor.git I don't get errors on non-repositoty pages.

    Today is Feb 18th, and I still get the errors. It seems (seems) that TeamCity actually fetches the pushed changes, builds, and deploys, but then afterwards, I see the errors. I'm not comfortable releasing new builds ...

    Hope you can use it. Best regards claus Holm, Denmark

  6. Claus Holm reporter

    And good afternoon.

    I have also been looking more into it. There seems to have come a timeout problem related to where I sit; however, it seems to have started around the same time as you did have LDAP problems last week.

    Two problems on top of each other is always a bitch to solve! So, if you say that all is well in your end (yes..?), then thank you very much for your help. I will start investigating more locally.

    best regards Claus Holm, cph

  7. Brian Nguyen

    Hi Claus,

    Thanks for the additional information. This kind of timeout can occur if it takes longer than 30 seconds to clone the repository. It sounds like a combination of this restriction and a slow connection is causing the problem.

    You can help alleviate the problem by using deploy keys (https://confluence.atlassian.com/display/BITBUCKET/Using+Deployment+Keys). This will allow your TeamCity server to clone over SSH, which does not have the same threshold.

    Cheers, Brian

  8. Erik van Zijst staff

    This kind of timeout can occur if it takes longer than 30 seconds to clone the repository.

    This is not entirely true. Web pages (and API calls) that take longer than 30 to return get killed. However, clones (and pushes, etc) do not have a timeout.

    Are you still seeing issues, or is there anything in particular you wanted me to look into?

  9. Magne Borg

    Hi,

    We are also experiencing the same connetion timeout problems reported by Claus Holm using TeamCity and BitBucket.

    The timeouts don't seem to be very consistent, but happen randomly. I've found a workaround since I have access to the actual build server and that is to open GitExtensions on the build server and perform a "Pull" operation for one of the repositories. That seems to refresh the connection to BitBucket and after the "Pull" operation completes the connection timeouts in TeamCity go away. But they usually come back in a few days...

    We are using deployment keys for all the builds on the build server.

    Have you found any other solution to this problem?

  10. Log in to comment