1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues


Issue #6813 invalid

error migrating current svn repository

Petar Bojkov
created an issue

Hi, I'm trying to migrate our current repository. I'm following the howto that we have received regarding this migration - http://go-dvcs.atlassian.com/display/aod/Migrating+from+Subversion+to+Git+on+Bitbucket I'm on step "Upload". Now, when I try to upload the locally created git repo to bitbucket with command: java -jar svn-migration-scripts.jar bitbucket-push dealmarket PASSWORD_REMOVED dealmarket DM I'm receiving error: ERROR: Error creating Git remote: https://dealmarket:PASWORD_REMOVED@bitbucket.org/dealmarket/dm I have removed the password from the command and the error but I'm sure that I have tried with the correct one. The repository itself is created and I receive an email with subject "You have hereby been granted admin access to dealmarket/dm.", but no data is imported in this repo because of the error we get.

I have also tried to use the command: java -jar svn-migration-scripts.jar bitbucket-push pbojkov PASSWORD_REMOVED pbojkov DM This command works without errors it imports all the data from the local git repo, but it creates the repository 'pbojkov/DM" which is not what we want. We want the repo to be named dealmarket/DM. Please advice how to proceed.

Comments (3)

  1. Marcus Bertrand [Atlassian] staff

    Hi Petar, the svn migration tools are maintained by the support team in Sydney. I've opened an issue for you at support.atlassian.com and you should have received a notification from us there. Please continue to work with us from that issue.

  2. PreviewNetworks

    We have almost the same issue: I'm on "upload" step and when java -jar svn-migration-scripts.jar bitbucket-push PreviewNetworks CMSHTML is executed script dies with ERROR: Error creating Git remote: https://PreviewNetworks@bitbucket.org/PreviewNetworks/cmshtml but repository is created by this command (can see it on https://bitbucket.org/). Moreover when I run command again script dies with "ERROR: <ul class="errorlist"><li>name<ul class="errorlist"><li>You already have a repository with this name.</li></ul></li></ul>"

  3. Log in to comment