Keep seeing "Merge failed" error when merging pull requests (BB-8040)

Issue #6847 resolved
Kevin Stanton
created an issue

See screenshot.

Then the merge doesn't succeed. Sometimes it does, sometimes it doesn't. Sometimes retrying fixes it. Hopefully :-\

Comments (11)

  1. Zachary Davis

    Hi Kevin,

    Unfortunately I can't tell much from the screenshot and I wasn't able to track down the corresponding error in our logs. Is there any additional information you can provide? Are you able to access any error information for the xhr request via Firebug or Chrome Dev Tools?

    Thanks, Zach

  2. Kevin Stanton reporter

    Not at this time, but multiple people here are experiencing the same error. I'll have to wait til the next time I try a merge.

    I'm also seeing errors regularly when stripping a changeset (it says it's unable to create a bundle file), etc.

  3. Diego Sainz

    Hi! We are experiencing the same issue since a couple of weeks now. Sometimes it worked after retrying two or three times. The last time it occurred (just minutes ago) this is the error code that the ajax response returned (and it seems it doesn't allows us two merge if we retry like other times):

  4. Log in to comment