1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues

Issues

Issue #6904 wontfix

error: Couldn't resolve host 'bitbucket.org' while accessing...

Richard Tape
created an issue

Hey folks,

I'm unable to do a git pull on a server in Canada from your service via ssh or https. I get the following errors:

SSH: git pull origin master ssh: Could not resolve hostname bitbucket.org: Temporary failure in name resolution fatal: The remote end hung up unexpectedly

HTTPS: git pull livehttp master error: Couldn't resolve host 'bitbucket.org' while accessing https://richardtape@bitbucket.org/richardtape/spes-live.git/info/refs fatal: HTTP request failed

My remotes are set up as following: git remote -v livehttp https://richardtape@bitbucket.org/richardtape/spes-live.git (fetch) livehttp https://richardtape@bitbucket.org/richardtape/spes-live.git (push) origin ssh://git@bitbucket.org/richardtape/spes-live.git (fetch) origin ssh://git@bitbucket.org/richardtape/spes-live.git (push)

Errm... help?

Comments (88)

  1. Zachary Davis

    Hi Richard,

    We haven't had any other complaints like this, and we haven't had any known downtime in the last few days. Perhaps there's a proxy problem or something on your side?

    Cheers, Zach

  2. Tom Wallace

    I have this same problem. I get the error: stderr: ssh: Could not resolve hostname bitbucket.org: Temporary failure in name resolution fatal: The remote end hung up unexpectedly

    at hudson.plugins.git.GitAPI.launchCommandIn(GitAPI.java:897)
    at hudson.plugins.git.GitAPI.access$000(GitAPI.java:42)
    at hudson.plugins.git.GitAPI$1.invoke(GitAPI.java:269)
    at hudson.plugins.git.GitAPI$1.invoke(GitAPI.java:248)
    at hudson.FilePath.act(FilePath.java:842)
    at hudson.FilePath.act(FilePath.java:824)
    at hudson.plugins.git.GitAPI.clone(GitAPI.java:248)
    ... 14 more
    
  3. HCMIS Admin

    I am able to log it to Bitbucket from the website, it when the Bamboo Plan tries to connects.

    System Error Details Build Apps Status Dashboard - Send to QA 13 : Errors getting changes for ASD-ASDSTQ-13 (java.lang.RuntimeException : com.atlassian.bamboo.plugins.git.GitCommandException: command 'C:\Program Files (x86)\Git\bin\git.exe' ls-remote https://hadmin:*@bitbucket.org/hadmin/apps-status-dashboard failed with code 128. Working directory was [.]., stderr: [error: Couldn't resolve host 'bitbucket.org' while accessing https://hadmin:*@bitbucket.org/hadmin/apps-status-dashboard/info/refs?service=git-upload-pack, fatal: HTTP request failed])

  4. Anonymous

    Same problem. Can't get from HostGator to Bitbucket.

    ssh: Could not resolve hostname gitbucket.org: Name or service not known fatal: The remote end hung up unexpectedly

    also

    ssh: connect to host bitbucket.org port 22: Connection refused fatal: The remote end hung up unexpectedly

  5. Bradley Pirman

    same problem when pushing from HostGator shared server...it was working at 2am today and not working at 12pm today

    ping bitbucket.org

    ping: unknown host bitbucket.org

    ping 207.223.240.182

    PING 207.223.240.182 (207.223.240.182) 56(84) bytes of data. 64 bytes from 207.223.240.182: icmp_seq=1 ttl=53 time=29.5 ms 64 bytes from 207.223.240.182: icmp_seq=2 ttl=53 time=29.3 ms

    traceroute 207.223.240.182

    traceroute to 207.223.240.182 (207.223.240.182), 30 hops max, 60 byte packets send: Operation not permitted

  6. Brian Nguyen

    Hi All,

    We haven't seen any issues connecting to the site generally so I would recommend contacting HostGator for more assistance.

    Also please be aware that we are currently being blocked in China, so this may be affecting access.

    Cheers, Brian

  7. Ryan Ye

    I had the same problem. I tried to troubleshoot, but failed. bitbucket.org was not resolved. So, I tried to ping www.google.com and it failed too. So, I rebooted my box and it is working now for me.

    The fix for me is that just reboot the computer. It will work.

  8. Brian Nguyen

    Hi everyone,

    In the event that you are unable to access bitbucket.org, the problem is almost always a local network issue.

    Please take a look at our network troubleshooting guide for advice on how to resolve this problem.

    If you continue to have difficulty please email us at support@bitbucket.org and we'll try and help you out.

    Cheers, Brian

  9. Manuel Cámara

    Yes, it's a local network issue. Now I can connect, I just change the git bash global http_proxy and https_proxy variables to connect throught a proxy with authentication.

  10. Eddie Spradley

    Nice, check this out. It's bigger than just Bamboo for me, it's any request. Started a few minutes ago out of the blue.

    [xxxxx html]# git fetch && git checkout development ssh: Could not resolve hostname bitbucket.org: Name or service not known fatal: Could not read from remote repository.

    Please make sure you have the correct access rights and the repository exists. [xxxxxx html]#

  11. ronantuantvt

    thanks young-jin park, It work for me . change DNS first edit file "/etc/resolv.conf" if any line doesn't exist , add some dns following example nameserver 8.8.8.8 nameserver 8.8.4.4 and try again...

  12. subbu

    thanks young-jin park, It work for me . change DNS first edit file "/etc/resolv.conf" if any line doesn't exist , add some dns following example nameserver 8.8.8.8 nameserver 8.8.4.4 and try again...

  13. eurekamedia_jakub

    SOLUTION: One common possibility for the Windows system to reject connections and resolve hosts is because Git-related services are blocked by anti-virus/firewall software. Examine your AV/FW software. For example Comodo Internet Security blocks Git services like ssh for the first time and you need to add 'em to trusted apps.

  14. Ramiro Santiago

    SOLUTION: Run this command git config --global --unset http.proxy git config --global --unset https.proxy

    Command to use :

    git config --global http.proxy http://proxyuser:proxypwd@proxy.server.com:8080

    git config --global https.proxy https://proxyuser:proxypwd@proxy.server.com:8080

    change proxyuser to your proxy user
    change proxypwd to your proxy password
    change proxy.server.com to the URL of your proxy server
    change 8080 to the proxy port configured on your proxy server
    

    it work for me

  15. Anonymous

    For me, the option "Use default operating system settings" was not working consistently. I have to set the custom proxy settings to work again.

  16. Anonymous

    it is work for me first edit file "/etc/resolv.conf" if any line doesn't exist , add some dns following example nameserver 8.8.8.8 nameserver 8.8.4.4 and try again...

  17. Ivan Freitas Jr

    [ OS X 10.11.2 ]

    Same problem here. To solve it, I turned on the Bonjour.

    sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist
    

    I hope it works for you too.

  18. Kamal elsaaid

    i had the same issue here but the solution of changing the DNS file didn't solve it, i have found another solution and it worked fine finally first of all you have to edit the " gitconfig " file you will find this file in that directory " C:\Program Files\Git\mingw64\etc " that file contains the directory of the certifications files that you need to authenticate the operation you do, but the directory was wrong , so you have to open " gitconfig " file and edit that line --> sslcainfo = C:/Program Files/Git/usr/bin/curl-ca-bundle.crt
    with that line --> sslcainfo = C:/Program Files/Git/mingw64/ssl/certs/ca-bundle.crt you have to check that the "ca-bundle.crt" file was in the that new directory first and it will work with you :)

  19. dimpisharma

    Hello Please help me regarding issues

    I am going to horizontal Merge Menu in git & then click on local merge screesn.jpgselect tracking branch but my option not show origin/Master. How to solve,please guide

    I have attached screenshot.

    Thanks dimplesharma

  20. Angelos Theodorakopoulos

    If you are using ssh make sure that there is a '/' after git@bitbucket.org and not a ':' for example: git clone ssh://git@bitbucket.org/<PROJ>/<REPO>.git Another reason might be a DNS issue as @young-jin park suggested. If you are using a local dns server (for example dnsmasq) then check the dns servers you are using on linux with command: nmcli dev show | grep DNS You might need to add google's dns servers which are 8.8.8.8 and 8.8.4.4

  21. Victoria Gonda

    I had a similar issue, where it was working, then all the sudden I started getting this error. However, I was able to ping bitbucket.org. A simple restart of my terminal ended up fixing it.

  22. Log in to comment