1. Bitbucket Website
  2. Public Issue Tracker
  3. master

Issues

Issue #704 resolved

Unable to clone repository under different scenes

rselas
created an issue

Hello guys!

I've been trying to clone my private repository without success on different scenarios.

I can login at web page without problems ;)

== case 1: with - proxy -- cygwin mercurial ==

{{{ $ hg --version Mercurial Distributed SCM (version 1.1) $ python -V Python 2.5.2

$ cat ~/.hgrc [http_proxy] host = 1X.1X.4X.10X:9090 passwd = **** user = rselas

$ hg -v clone http://bitbucket.org/rselas/lamath http authorization required realm: Bitbucket.org HTTP user: rselas password: abort: Error

$ cat .wgetrc http_proxy = 1X.1X.4X.10X:9090 https_proxy = http://1X.1X.4X.10X:9090 proxy_user = "rselas" proxy_password = "****"

$ wget http://bitbucket.org/rselas/lamath --2009-06-08 16:47:59-- http://bitbucket.org/rselas/lamath Connecting to 1X.1X.4X.10X:9090... connected. Proxy request sent, awaiting response... 301 MOVED PERMANENTLY Location: http://bitbucket.org/rselas/lamath/ [following] --2009-06-08 16:47:59-- http://bitbucket.org/rselas/lamath/ Connecting to 1X.1X.4X.10X:9090... connected. Proxy request sent, awaiting response... 401 UNAUTHORIZED Authorization failed.

$ wget http://rselas:pass@bitbucket.org/rselas/lamath --2009-06-08 16:49:34-- http://rselas:password@bitbucket.org/rselas/lamath Connecting to 10.15.40.104:9090... connected. Proxy request sent, awaiting response... 301 MOVED PERMANENTLY Location: http://bitbucket.org/rselas/lamath/ [following] --2009-06-08 16:49:35-- http://bitbucket.org/rselas/lamath/ Connecting to 1X.1X.4X.10X:9090... connected. Proxy request sent, awaiting response... 401 UNAUTHORIZED Authorization failed. }}}

== case 2: with - proxy -- tortoise mercurial == TortoiseHG 0.7.1

{{{ $ ./hg.exe --version Mercurial Distributed SCM (version 1.2.1)

rselas@91773m /cygdrive/c/Archivos de programa/TortoiseHg $ ./hg.exe -v clone http://bitbucket.org/rselas/lamath ~/lamath abort: http authorization required

rselas@91773m /cygdrive/c/Archivos de programa/TortoiseHg $ ./hg.exe -v clone http://rselas:pass@bitbucket.org/rselas/lamath ~/lamath abort: authorization failed }}}

Ive tested it at home (without proxy, same versions as before) but same result.

I've tried other sceneraios as well (ssh) I can provide tests if you ask me.

I don't know if Im doing something wrong or it is a server authentication problem.

Regards,

Raúl

Comments (12)

  1. Jesper Nøhr
    • changed status to open

    You're not doing anything wrong, but Mercurial inherently has some issues with using proxies. You said you've tried without proxies and you got the same result? In that case, I'd like to see the output for that (with --debug and -v.)

  2. rselas reporter

    Hi Jesper.

    I've tried again without proxy and it works fine. Sorry, I must made some error while trying it before.

    Do you know where I could find information about the mercurial proxy issue?

    Thanks in advance,

    Raúl

  3. Alexey Lustin

    same problem for me behind Squid proxy

    $~/python -V
    Python 2.6.2
    $~/hg -v --version
    Mercurial Distributed SCM (version 1.3.1)
    
    Copyright (C) 2005-2009 Matt Mackall <mpm@selenic.com> and others
    This is free software; see the source for copying conditions. There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE
    $~/hg -v clone --debug http://allustin:*pass*@bitbucket.org/allustin/redmine-core-and-extension/ ./
    using http://bitbucket.org/allustin/redmine-core-and-extension/
    proxying through http://192.168.0.2:3128
    http auth: user allustin, password *******
    sending between command
    http auth: user allustin, password *******
    http auth: user allustin, password *******
    http auth: user allustin, password *******
    http auth: user allustin, password *******
    http auth: user allustin, password *******
    http auth: user allustin, password *******
    abort: authorization failed
    

    without proxy clone correctly

  4. Alexey Lustin

    same problem for me behind Squid proxy

    $~/python -V
    Python 2.6.2
    $~/hg -v --version
    Mercurial Distributed SCM (version 1.3.1)
    
    Copyright (C) 2005-2009 Matt Mackall <mpm@selenic.com> and others
    This is free software; see the source for copying conditions. There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE
    $~/hg -v clone --debug http://allustin:*pass*@bitbucket.org/allustin/redmine-core-and-extension/ ./
    using http://bitbucket.org/allustin/redmine-core-and-extension/
    proxying through http://192.168.0.2:3128
    http auth: user allustin, password *******
    sending between command
    http auth: user allustin, password *******
    http auth: user allustin, password *******
    http auth: user allustin, password *******
    http auth: user allustin, password *******
    http auth: user allustin, password *******
    http auth: user allustin, password *******
    abort: authorization failed
    

    without proxy clone correctly

  5. Arun I B

    Yea, I am behind an authenticated proxy...It seems the issue has vanished. The Internet connection was a bit slow then, may be that was the issue.

  6. Log in to comment