Issues

Issue #7072 invalid

HTTP 502 with large Mercurial pushes (BB-8463)

Rasmus Fjord
created an issue

Hey :)

Ive tried to push a new revision to our repository : https://bitbucket.org/Rosendahlsweb/sydvesjylland.com (Private)

But when its finished bundling, and sending it gets stuck on 100,01% and after a few min of nothing happening it throws :

HTTP Error: 500 (Internal Server Error)

Ive tried to get more info with debug and such but no more is comming out, hope you can help.

I dont know if i posted this the right place :)

Comments (19)

  1. Nicolas Venegas

    Hi Rasmus

    There was a problem with your repository on our servers. I've run hg recover and hg verify, and the repository is now at revision ce607db2d28a.

    Can you try pushing again, perhaps after running hg verify locally?

    Cheers

    Nicolas

  2. Rasmus Fjord reporter
    • changed status to open

    Hey Nicolas this time its throwing something else at me. I did a verify and recover and there where nothing wrong it said.

    So i did a push --debug to get the trace and this times an Error 502 bad gateway : error

  3. Nicolas Venegas

    OK, looking at our errors I see your recent attempts to push have failed because of a lock being held on the repository.

    I've once again run hg recover putting the repository back at revision ce607db2d28a (the same revision as yesterday).

    How long does it take before you see that error after you run hg push?

    Cheers

    Nicolas

  4. Rasmus Fjord reporter

    Well its quite big, It takes about 50 min to push it, im thinking about deleting my revision, clean some of the files out(images etc) and then try to push it again. Will this do anything different ?

  5. Rasmus Fjord reporter

    Hey Brodie :)

    Thx for getting back to me! :)

    Sure i will, how do i do it ? Ive normally just used tortoise hg for windows so this is actually my first repo to try working with through cmdline.

  6. Brodie Rao staff
    • changed status to open

    Hi Rasmus,

    I hope you were able to get things working with SSH.

    I've put an internal issue in our backlog to address the HTTPS issue you're seeing. We'll update this issue when we have more information.

    Thanks!

  7. Rasmus Fjord reporter

    Hey Brodie :)

    Just got home from vacation so havnt had a chance yet, but will give it a spin when i have 5 min of freetime.

    Great that you found a bug with it :)

    A bonus info for you is that when i opened the specific repository in tortoise HG it takes forever to load it up, and sometimes it crashes. Sure there is a decent amount of files but nothing i havent seen in other repositories.

  8. Oleg Dorovskoy

    Hi all,

    We have a very similar issue: HTTP Error: 500 (Internal Server Error). The difference is that we are trying to push our project to a fresh repository on BB (created yesterday).

    hg verify does not show any errors on local repo.

    Neither HTTPS nor SSH work for us.

    Brodie, could you give us the status update?

    Thanks in advance, Oleg

  9. Esty Heller (Weiss)

    I just had this as well. Tried pushing a huge repository via https to empty bitbucket repo, it took about 10 hours, and at the very end, failed with the 502 error I will try ssh now.

  10. Log in to comment