Issue #7164 resolved

Adding a service doesn't work

Yashi Developers
created an issue

I'm trying to add the POST service to a repository, and the spinner keeps going, and I get a bunch of errors in the Chrome debug console.

This happens once in a while for me with Ajax requests on the site. This time I tried it 3 times and it kept happening, so here I am. :)

I expanded the error so I can get some details for you, and attached a screenshot that will hopefully help a bit.

I'm on OS X Mountain Lion Google Chrome Version 26.0.1410.65

POST catcher.js:197

XMLHttpRequest.send catcher.js:197

send a1c5fa2b7cf9.js:185

l.extend.ajax a1c5fa2b7cf9.js:179

(anonymous function) a1c5fa2b7cf9.js:1313

l.event.dispatch a1c5fa2b7cf9.js:92

g.handle.h a1c5fa2b7cf9.js:84

Comments (9)

  1. Brodie Rao


    Thanks for the detailed error output!

    I took a look at our server logs and I don't see a response logged for that request. That might mean there's a network issue or that our web server wasn't able to generate any kind of response. I'll need to do some more digging to figure out what's going wrong.

    If you're able to reproduce it easily, could you provide a screenshot of the failed POST request from the network tab in the inspector? You'll need to click on the network tab before you hit the "add service" button.


  2. Brodie Rao

    In the sources tab, can you tell me what it says the full URL is for catcher.js? If it's from a Chrome extension, can you try disabling it and check if the AJAX requests still fail?

  3. Log in to comment