Issues

Issue #7327 resolved

Abandoned transaction found - run hg recover!

rjwiffen
created an issue

Hi. I'm using TeamCity on a build server, and I keep getting an error about being unable to pull changes from BitBucket, so I'm currently unable to build and deploy. This is in the logs: "abandoned transaction found - run hg recover!". For what it's worth, I did try to do a pretty big commit yesterday, if that makes any difference.

Is there any way for me to do this in the admin interface, or does someone else have to do it?

This is my repository: https://bitbucket.org/rjwiffen/accountsflow

Comments (7)

  1. rjwiffen reporter

    This might be a dangerous idea, but should I try stripping recent changesets and pushing my local changes again? Or could that just make it worse?

  2. rjwiffen reporter

    Well, I've tried a few things. First of all, cloning/deleting original/renaming. Then cloning/deleting original/cloning. I still get the "abandoned transaction" problem when I try to pull from the original repository URL.

    The cloned version (accountsflow2) seems to work, but even after cloning or renaming it back to accountsflow, that has the same problem.

    No idea what I'm doing wrong?

  3. Michael Frauenholtz staff

    Hi rjwiffen,

    It looks like the repository is fine on our end. Can you run hg recover locally from a command prompt? If that doesn't fix the issue, please paste the output here so we can investigate further.

    Cheers,
    Michael

  4. rjwiffen reporter

    Sorry, should have mentioned I tried that. It just says "no interrupted transaction available", so I'm assuming it's OK locally.

  5. rjwiffen reporter

    Ahh!! The problem was in TeamCity itself on the build server. I had to go into C:\TeamCity.config\system\caches\mercurial\hg... (multiple directories) and run hg recover in there. That seems to have done it.

  6. Log in to comment