Can't import repo from github

Issue #7328 resolved
Former user created an issue

I can't import repo from github. Keeps on failing time after time!

No matter if is public or private.

Keep on getting this....

Your import has failed. For more information, check the log below. You can also try your import again.

00:18:00 git import for: https://github.com/TeamDIRT-Mazda/packages_apps_Calculator.git 00:18:00 Cloning https://github.com/TeamDIRT-Mazda/packages_apps_Calculator.git... 00:18:00 Done 00:18:00 Fixing repository permissions... 00:18:00 Computing repository size... 00:18:00 Remote Git clone failed: <class 'orochi.base.RepoError'>: 'Mazda/packages_apps_calculator' isn't a repository

Comments (45)

  1. MrGuy

    Very same issue here, doesn't matter if I use git:// or http://

    NOTE: Should say that this isn't github - I'm trying to clone from git.libssh.org

  2. Michael Frauenholtz staff

    We are investigating this issue now. We'll update this issue when we have more information.

  3. Rob Shannon

    still failing: 20:11:21 Remote Git clone failed: <class 'orochi.base.RepoError'>: 'Lloir/android_hardware_qcom_display' isn't a repository

  4. Clariner Limited

    I'm also getting this error Remote Git clone failed: <class 'orochi.base.RepoError'>:

    I'm trying to import a github repo.

  5. Beautylish

    I'm getting the same:

    14:41:38 Fixing repository permissions... 14:41:38 Computing repository size.... 14:41:40 Remote Git clone failed: <class 'orochi.base.RepoError'>: '###' isn't a repository

  6. Danny Englander

    I'm having the same issue when I use the UI to import located at:

    https://bitbucket.org/repo/import/github
    

    ... and I've already authorized the app on the Github end so I am not sure if I should open a new issue. When I go to "view log", it simply reloads the page.

  7. Nicholas Waltham

    I am also seeing the "destination path already exists and is not an empty directory" problem too.I am attempting to import from Unfuddle. It had worked yesterday with a different repo on unfuddle....

  8. Roni Kantis

    Same problem here, tried with two private repositories from github. It should be noted that i had cloned and deleted those repos earlier, could that create the conflict?

    12:57:05 git import for: https://github.com/sopranobrainalliance/laakarikeskus-ajanvaraus-api.git 12:57:05 Cloning https://github.com/sopranobrainalliance/laakarikeskus-ajanvaraus-api.git... 12:57:05 fatal: destination path 'druidfi/laakarikeskus-ajanvaraus-api' already exists and is not an empty directory. 12:57:05 Remote Git clone failed: <class 'bitbucket.apps.async.tasks.ImportException'>: Command failed. Return value: 128

  9. Daniel Bennett Account Deactivated

    This has been resolved. Thank you for your patience while we worked through this problem.

  10. Marcus Bertrand staff

    If you're having any issues, please come to support.atlassian.com under the Bitbucket project -- Creating an account is free.

  11. Todd Orr

    Creating an account may be free, but I don't know that I have a support entitlement number for bitbucket.

  12. Erik van Zijst

    @picktags we're not aware of any issues with the importer. Care to share the import log (copy/paste or a screenshot like above) with us at support@bitbucket.org ?

  13. jérémy piednoel

    I had the same issue and it was due to the github "Two-factor authentication". I had to disable it temporary github side

  14. Peter Purmonen

    I'm getting "remote: Invalid username or password." and "Remote Git clone failed: <class 'bitbucket.apps.async.tasks.ImportException'>: Command failed. Return value: 128" in the the import log. I know I'm entering the correct github user/pwd and I've turned 2FA off in Github.

    This issue is certainly not resolved. The problem is however a dealbreaker, I''m not doing all my repos manually via my local machine. Can it be Github making it deliberately difficult to migrate?

    Edit (added): I've asked Github if they're blocking the import related requests from Bitbucket on purpose. I mean, it's Microsoft puppeteering behind the scenes.. ;-)

  15. Saso

    We are trying to migrate from self-hosted Gitlab (hasn't been updated for 3 years) to Bitbucket Cloud, but are getting this error: Peer's Certificate issuer is not recognized. If I want to clone it locally over https, I also get this error. But if I set the config property sslVerify to false, then the error is gone and I get the popup to enter credentials so that it works locally then. So I have to set sslVerify on Bitbucket cloud huh? :P

    Is this solved, is it in the pipe for fixing or what is wrong with importing?

  16. Log in to comment