1. Bitbucket Website
  2. Public Issue Tracker
  3. master

Issues

Issue #7343 resolved

Issue with import from sourceforge

AdamBlack
created an issue

I tried to import my code for https://sourceforge.net/p/ucomponents/ and received confirmation that the repositery was imported.

"The remote Mercurial import you started for http://ucomponents.hg.sourceforge.net:8000/hgroot/ucomponents has completed successfully."

However nothing was imported. The URL that bitbucket attempted to import from "http://ucomponents.hg.sourceforge.net/hgweb/ucomponents" appears to have no code. A web interface for mercurial is however available at "http://hg.code.sf.net/p/ucomponents/code"

By bypassing the restrictions for the import field and putting in "http://hg.code.sf.net/p/ucomponents/code" instead of the default "http://ucomponents.hg.sourceforge.net:8000/hgroot/ucomponents" I was able to successfully import the project.

Please consider: * making the input field editable by default, * checkin if the repository is empty and warn about it. * automatically determining where to import from

Comments (10)

  1. AdamBlack reporter
    • changed status to open

    Thank you for your quick response. The present solution partially solves the problem.

    The reason my URL has "code" at the end of it is how I named my repository. Projects such as opt4j use a different repository name. e.g. with a url of " http://hg.code.sf.net/p/opt4j/hgroot". Projects such as "ncid" haver multiple repositories (see the mercurial button on http://sourceforge.net/p/ncid/code/ci/default/tree/ for a dropdown that list them)

    The format for sourceforge for projects using the new interface can be found at http://sourceforge.net/p/forge/documentation/Mercurial/

    Please be aware that some older sourceforge projects still use the "classic" interface and are only available at the older format of the URL. e.g. optipng

  2. Brian Nguyen

    Hi,

    It looks like Sourceforge has updated their svn code hosting. To get this to work, type as3htmlparser into the project name field and code into the mount point field.

    You will see an warning about not finding trunk but you can ignore it.

    I've attached an image of what you should expect.

    Cheers, Brian

  3. Richard Lukins

    Was trying to import a couple of projects from SourceForge and both gave errors in the setup screen. I finally worked out how to get one of them correctly "described" in the import panel not to give errors but not the other.

    Maybe for "newbies" like me some extra help and examples would be good, as I'd have not tried to hit import with the error showing for 1 project had I not found this thread. But clearly the error is either wrong or should be a more explicit "warning" as the settings worked !? But also led to a failed attempt I cannot delete!

    an example using the SourceForge command line translating to fields would be good!! ie

    svn checkout svn://svn.code.sf.net/p/web-erp/code/trunk web-erp-code
    

    showing: Project name = web-erp (the FIRST bit after "svn://svn.code.sf.net/p/" ) Mount point = code/trunk (the bit after the Project name without a leading "\") would have saved me loads of time and frustration !!

    However I now have a repository called "web-erp" that failed due to the wrong settings and cannot delete it !! any help on this?

    For the other SourceForge Project I was able to import but with a "No repository exists at that URL" message, but it seemed to work and come across.

    the sourceforge pull was hg clone http://hg.code.sf.net/p/frontaccounting/mercurial frontaccounting-mercurial

    It appeared to work using: Project - frontaccounting Mount - mercurial and using mercurial as the type but not sure if this is going to fail later in life ?! How important is the error?

    Being no pro at this, I'm a little disappointed by the lack of help, explanations or examples ... indeed the error itself is vastly unhelpful !!

    Look forward to hearing any pointers or if I need to redo the import!

  4. Richard Lukins

    Sadly, so much for simplicity, tried the above format for SuiteCRM

    git clone git://git.code.sf.net/p/suitecrm/code suitecrm-code
    

    using project "suitecrm" Mount "code", but despite the HTTP looking just like the Sourceforge example it refused to find the project and ignoring the error created another dead and undeleteable project. Use the GIT import and it worked fine!

    I guess the SourceForge import needs some work?

  5. Log in to comment