Issue #7402 open

Online editor does not fire events for hg repositories (BB-8735)

Kaz Nishimura
created an issue

When I made a change with the online editor, it seemed service integration hooks were not executed.

Comments (26)

  1. Michael Frauenholtz staff

    Hi Kaz,

    Editing a file online should trigger the service hooks. However, we are investigating an issue for delayed service hooks, which this may be related to. We'll let you know when we have a resolution for this.

  2. Brian Nguyen

    Hi Kaz,

    We have heard a couple of other reports of our services not working properly, so we are investigating this further.

    Can you tell us which services you have configured and the repository that is affected? It would help us greatly.

    Cheers, Brian

  3. Brian Nguyen

    Hi Kaz,

    Looking at that repo, it looks like the push event was lost for that commit. Earlier in the week we were having some issue with our background tasks that may explain this.

    I do not believe that this issue is related to online edit though.

    I'm monitoring our channels to see if the problem is still occurring but unfortunately it is hard to determine the exact error right now. Please let us know if you do see this error again and we will investigate this further.

    Cheers, Brian

  4. Brian Nguyen

    Hi Kaz,

    I believe that the problems with our events has been fixed now, so I'm closing this issue. However, if you are still seeing these issues please reopen this.

    Cheers, Brian

  5. Brian Nguyen

    Hi Kaz,

    Yes, there is a relationship. The mechanism that sends tweets is the same as the one adds items to the activity feed. Unfortunately, once an event has been lost there is no way to recover it. So you won't be able to receive the tweet now.

    However, new events should be working now, so let us know if you see any new occurrences of this bug and we will look into it.

    Cheers, Brian

  6. Kaz Nishimura reporter

    I have no problem for commits via remote push. It happens when I made commits on the online editor. But it could happen when I made a merge from the web UI too. I don't remember well for the merge.

  7. Wilko Nienhaus

    I tested this (online editing) yesterday, before the status of this issue was changed to resolved and also after the status was changed to resolved, and sadly no hooks were fired during either attempt.

    The new issue created (#9161) appears to be only vaguely related (of course it might be connected to the underlying reason). I am afraid that the online editor problem might go unfixed, now that both this issue and issue #8327 are effectively closed.

    Is the new issue really the underlying problem, or should this issue rather be reopened?

  8. Log in to comment