1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues


Issue #7629 closed

Importer reports wrong error (BB-8807)

Tom Ekberg
created an issue

First I created a GIT repository (rounduplm) to hold the contents.

Then I tried to use the importer to retrieve files from a remote SVN repository which required authentication. As part of the authentication I entered my username/password. When I hit ENTER the error I got back was 'authentication error'. I did it 3 times to make sure I typed it in right and caps lock was off. Same error. I happened to scroll down and noticed that it was complaining that the GIT repository already exists. I deleted the rounduplm GIT repository and used the importer successfully this time.

The importer improperly reported 'authentication error' when it should have reported something like 'repository already exists' at the top of the page.

Comments (2)

  1. Jon Mooring staff

    Thanks for reporting this bug, Tom. I've added an issue in our internal bug tracker and will update this public issue when we have fixed it.


  2. Log in to comment