1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues

Issues

Issue #7819 resolved

Problem with auto-closing issues when merging pull request (BB-8985)

Dave Kaminski
created an issue

The short story is that "close issue #33" works as expected but "closes issue #33" does not.

Whether the text is in the message of a commit that gets merged in as a pull request, or in the message of the merge commit itself, "close" ALWAYS works and "closes" NEVER works.

"See" works as expected, adding a comment to the issue with a reference to the commit.

I have not tried the other verbs.

Comments (9)

  1. Dave Kaminski reporter

    Here are links to problematic commits in a private repo.

    Here is one (using "closes") that was pushed to a separate repo and then brought in via a pull request to the repo with the issue tracker:
    https://bitbucket.org/irdgaming/kinect-physical-therapy/commits/966394156177b4fa729349c602833f7bf64ef599

    And here is a merge commit (using "Closes") from accepting a pull request:
    https://bitbucket.org/irdgaming/kinect-physical-therapy/commits/4237d9dc42d7774a396205e9269dfcf70bd19866

    For good measure, here's one (using "close") that worked as a commit that was pushed to a different repo and then brought in via a pull request:
    https://bitbucket.org/irdgaming/kinect-physical-therapy/commits/4bb9f864875423ed48f810b86d47b8676a7beec9

    And here's one (using "See") that worked in a merge commit from accepting a pull request:
    https://bitbucket.org/irdgaming/kinect-physical-therapy/commits/2a510ecfaaf5ac6da07284891e42bd3e76577b15

  2. Erik van Zijst staff

    I'm not able to reproduce that either. Again, everything transitions as expected, both when the command is in the commit that was on the source repo, as well as with the command as part as the Bitbucket-created merge commit.

    I can see that your issue #30 didn't get closed even though you have a commit that addresses it, but I'm unable to tell what happened.

    I've raised an internal issue for this and will leave this public issue open for other people to discover and comment on.

  3. Log in to comment