404 when calling create against a Bitbucket Deploy keys API endpoint for one user

Issue #7827 resolved
Rowan Williams
created an issue

Hi there,

I have a service running that uses the API to add a deployment key to an account.

For all of my users this works successfully except one where they experience a 404 message from the Bitbucket API when trying to add a deploy key.

trying to add a key to: https://api.bitbucket.org/1.0/repositories/rowilliams/TestRepo/deploy-keys/

What is the 404 not found for (no more info in the response from what I can see).

And why does this only affect one user?

Comments (11)

  1. Rowan Williams reporter

    I'd add that this works for all of my other users.

    The Test Repo is an uninit'ed repo - but with this user i've tried all of their repos (they changed their password and actually given me access).

    also, have tried this with a brand new account ("oncheckintest") and I can't replicate it even by creating a repo named the same thing, or un-init'ed.

    Unsure what's different. Wish the response body provided more details.

  2. Erik van Zijst staff

    Can you capture the full HTTP request (the raw stuff on the wire, with all the headers and everything)? That should allow us to solve this mystery.

    Now your HTTP headers will contain your username and password (unless you're using OAuth), so you'l want to sent that directly to support@bitbucket.org and mention my name and this ticket so I can pick it.

  3. Erik van Zijst staff

    @Michael Smith Have you verified that you are using the correct URL (see my first comment on this issue)? Also, can you make sure that the user you are authenticating as has admin access to the repo in question?

    If that doesn't resolve the issue, could you email us at support@bitbucket.org and mention my name and this issue so I can pick it up from there?

    It would be tremendously helpful if you are able to attach a full HTTP level request dump (as I suggested to @Rowan Williams).

  4. Log in to comment