1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues

Issues

Issue #7911 resolved

Adding comments to certain commits does not work - field does not respond to entry

Taron Millet
created an issue

Certain recent commits to my repository do not work when I try to comment on them, but others do. I have tried multiple users, multiple computers, multiple operating systems, and multiple browsers, all with the same result.

In the commits that don't work, the field is there to type in a comment, but when typing something into it it doesn't react. On other commits, the field expands as I typed stuff in to give more space and show editing buttons, but now it stays as only big enough to show one line at a time.

More importantly, the button to actually submit the comment never appears, rendering the field completely useless on these commits.

See comments below for more details and examples.

Comments (12)

  1. Taron Millet reporter

    I get the same problem with Google Chrome and with Internet Explorer. I tried a Windows XP machine and a Windows 7 machine with both browsers. As mentioned I had no problems yesterday on either machine.

  2. Taron Millet reporter
    • changed status to open

    I have since discovered that this only affects certain commits. Some of them I can still comment on just fine, others I can not. I can't tell what the difference is between the ones where the comment field works and the ones where it doesn't, but it is consistent about which commits will allow me to comment and which will not.

    Its a private repository, but would it help to have links to examples that will and won't work?

    WORKS:

    DOES NOT WORK:

    I have confirmed that the other users of this repository experience the same thing - they can comment on the ones I can comment on, but can't comment on the ones I can't comment on. They are using a range of different systems and browsers.

  3. Taron Millet reporter

    More details:

    I just noticed that the ones that don't work also don't seem to properly load the "participants" in the commit. Up on the top right it says:

    Participants Loading...

    forever, and under watchers, it does not list the person who made the commit as actually watching it.

    Clicking "Watch this commit" on these broken ones doesn't do anything either. Other features also don't function properly, for example clicking the drop-down menu next to the eye ball to set your notification options does not respond.

    I have examples of commits that are "broken" like this from multiple users, so it isn't just one user doing something wrong with their commits or anything like that.

    I have not yet been able to identify any common traits among the ones that show up broken like this. I have tried diffing the source html and there are definitely significant differences (beyond the obvious of whatever was different between the actual commits), like whole sections of scripting that are in one commit but not the other.

    Some changes I noticed include:

    • The non-working version has a whole extra section contained in it in a div id called "share" that seems to be talking about admin access and such, that surprisingly the working version does not contain (or has it somewhere completely different in the file).

    • The clone repository link for the non-working version is an https link. The clone repository link for the working version is an ssh link.

    • As mentioned above, in the participants section it just says "Loading..." instead of having the little boxes with participants in it in the non-working ones.

    EDIT: I mentioned before html differences between the comment boxes but I think I accidentally grabbed the source of one where I had already got the comment box to open (which of course doesn't happen on the non-working ones), before opening it they look the same, so disregard that.

    If there's any more info you need let me know.

  4. Log in to comment