Couldn`t add SSH keys

Issue #8027 resolved
Viktor created an issue

Dear Sir/Madam,

I have a trouble with adding SSH keys in my bitbucket account. I click on the button "Add key", pste my key and type title of this key then click on "Add" and nothing happens. Dialog of adding key is still here but "Add" button displayed as a disabled button. Try to refresh SSH keys page and see that no keys were added. How to solve this problem?


Comments (19)

  1. Viktor reporter

    Yep, I`ve already tried to generate default key with this tools some times by bitbucket docs(key format is approxiamtely the same, i.e. I put correct key) but no messages or errors appears when I click "Add". Only "Add" button marks as disabled.

  2. Viktor reporter

    Ok, I`ve fixed it. It seems I copy and paste wrongly. First time I just mark the key on bash and copy it then paste but it seems it has some extra spaces or something else. I just open via notepad then Ctrl+A and Ctrl+C after that I paste everything to SSH Key page succesfully.

  3. Edwin Dalorzo

    I am having the same problem and I am pretty sure it has nothing to do with my way to copying the key. It started happening yesterday. I added a colleague's key and then I tried to add another and the web dialog gets frozen there. Nothing happens. If you close it and open it again, it still contains the key information, but never finishes the submit of it.

    I tried removing an existing key and adding it again, and same problem.

    Definitively something is happening with this.

  4. Viktor reporter

    Do you copy and paste directly from Git Bash? If so then try to open manually via Notepad (by default is located in ~/.ssh/ or in C:/Users/User_Name/.ssh/ So, open it throughout your favorite editor, copy and paste it in SSH Keys page. After such a way I have success finally. Copy&Paste via Git Bash directly was faulty for me.

  5. Edwin Dalorzo

    You can see how the dialog looks here:

    Adding SSH Keys Problem

    It gets stuck there, and even if you close and reopen the Add SSH Keys dialog, you still gt this frozen screen.

    You can see the "Add Key" button is disabled.

  6. Edwin Dalorzo

    I opened my file in Sublime Text and copied (Ctrl+A + Ctrl+C) and then simply pasted it here.

  7. Edwin Dalorzo

    Page refresh gets rid of the frozen screen, but I am still not able to add keys. If I try, I get into the same scenario again.

    My key worked just fine in Github when I followed the same process of copying and pasting.

  8. Viktor reporter

    Hm, I don't know what to do in this case. I'm a new here and with git at all but my way helps me. I can only advice you to try notepad (but in general I don't see any difference between yours editor and notepad in copy&paste functionality) and if your page is frozen even you refresh the page then try to log out and log in, may be try to use another browser(the same don't see any sence but sometimes misterious things solves by misterious way). However, I'm pretty sure it`s something like a bag in this form (edit form isn't working too) actually because form should parse key string correctly as it is in github probably.

  9. Edwin Dalorzo

    The browser is reporting a BAD REQUEST (404) when you click the add key button. So, something must have changed in the code.

  10. Marcus Bertrand staff

    We recently made a change to our API that broke the error messages. We just fixed it earlier today. Sorry about that. You should now see valid error messages when adding keys.

  11. Али Тлисов

    the same issue again. once you press add key it gets grayed and nothing happens. but only in russian interface language. after changing language to english all is fine.

  12. Stefan Laurie

    The problem for me was, I was using the Opera Browser, I switched to Firefox and it immediately added the key.

    More detail: In Opera, in the Developer Console, I used the Network tab to see the response I was getting. It said CSRF Verfication Failed, which I googled and found it's a problem with Opera and Bitbucket (but I didn't look into it further)

  13. Log in to comment