Keyboard does not pop up on Online Edit on iPad (BB-9619)

Issue #8188 closed
created an issue

When I log in go my repo ( on my Mac, I get an edit button when viewing source files and I can edit them. However, when I log in to my repo on my iPad, I don't get the edit button and consequently I can't edit the source files, although I was able to do so some time ago. Also, there is nothing visible on the page that says that I am logged in, although I must be logged in because I can edit issues and change settings on my profile. It is almost like I am logged in but I am not.

Comments (19)

  1. Brian Nguyen


    This is very strange. Could you send us some screenshots one from your Mac and one from your iPad. It should help us a bit.

    From your description it looks like you are not logged in on your iPad or perhaps logged in as a different user. You can see who you logged in as by looking in the top-right hand corner of the page. You should see your avatar or the login button if you are not logged in.

    Cheers, Brian

  2. Mike Hannibal


    On the iPad using Safari I am presented with the Edit button, but when I select it and touch within the source to edit I don't get an iPad keyboard. If I use an external Bluetooth keyboard, I still cannot edit the file - no input gets from the keyboard to the file. Just as a note I'm typing this on the same iPad, in Safari with the same BT keyboard. To be clear I'm logged in properly with admin rights on the repo. This seems like a bug to me.

  3. trijezdci reporter

    Bitbucket seems to be confused about the log-in status.

    On the one hand I know I am logged in because I have profile and admin access which I wouldn't if I wasn't logged in. On the other hand it seems I am not logged in because I am presented with a disabled edit button. This has got to be a bug.

  4. Mike Hannibal

    I don't get the same issue as trijezdci. For me the edit button is enabled (as long as I'm on the latest version of the file) and when it's touched it gives me the edit window. However it never provides a keyboard and never accepts input from an external keyboard.

  5. WWW Developer

    Edit button is enabled in my iPad. But it never provides a virtual keyboard and never accepts input from an external keyboard. so we have no ways to edit the code in ipad.

  6. Paul Stone

    Maybe this is related to the issues discussed here?:

    In the meantime, here is a (terrible!) video of how I've been able to consistently get the iOS keyboard to show up:

    But basically, this is how I get it work:

    1. Tap 'Edit' button
    2. Wait for editing screen to load
    3. Tap the file's title bar. You will see the whole area flash black (this is the focus being set, I think)
    4. Now tap where you want to edit in the file.
    5. The iOS keyboard should now display for you.

    Thanks, Paul.

  7. Stuff Andy Makes

    I would like to ditto this one. I'm on he latest iOS on the latest retina iPad and the keyboard came up earlier today, now it doesn't. When the keyboard is up, I cannot tap the edit area again to paste in text from the clipboard. It appears there may not be a real text edit box there? Either way, sure would love to be able to paste text in on iPad.

  8. geoff-grav

    Is there any way that you can support a Simple "Edit in a Textarea field". Just detect the device and if it is a mobile/Tablet device that you can show this option at the bottom next to editor mode and indent mode. It doesn't need to be fancy. No need for syntax highlighting, line numbers, special tab indentation, etc. Just a simple plain text option. This should also resolving scrolling issues as it it very difficult to scroll through divs in mobile devices.

    I can't get the Editor to work with Android Devices. I can't use the Backspace to remove any characters. It also gets glitchy when trying to add characters. I tried setting the Editor to "Plain Text" mode, but that does not help. I have tried many devices and many browsers for the Android Devices and all seem to have the same issues.

  9. Log in to comment