Unable to Upload Files in Downloads

Issue #8488 resolved
Bitbucket user
created an issue

On the Downloads page, after pressing "Add File" button, the page redirects to https://bbuseruploads.s3.amazonaws.com and hangs.

Comments (24)

  1. Erik van Zijst staff

    I'm unable to reproduce this problem.

    Where do you see things hanging on that amazon URL? Are you looking at your browser's web inspector console?

    If so, can you even reach that host? Can you resolve the hostname or ping the IP properly?

  2. Bitbucket user reporter

    The https://bbuseruploads.s3.amazonaws.com redirect shows up in the safari address bar, and in the inspector for safari, chrome and firefox.

    The ping request times out:

    $ ping bbuseruploads.s3.amazonaws.com PING s3-2-w.amazonaws.com (207.171.185.201): 56 data bytes Request timeout for icmp_seq 0

    $ ping 207.171.185.201 PING 207.171.185.201 (207.171.185.201): 56 data bytes Request timeout for icmp_seq 0

    I did a remote online trace route and it also hangs with that address.

  3. Erik van Zijst staff

    That host is part of Amazon's S3 infrastructure (not something we host) and is online. It does not seem to respond to ICMP (I'm also not getting ping replies), but is definitely listening on port 443:

    $ telnet  bbuseruploads.s3.amazonaws.com 443
    Trying 207.171.189.81...
    Connected to s3-2-w.amazonaws.com.
    Escape character is '^]'.
    ^]
    telnet> quit
    Connection closed.
    

    What network are you trying this on and do see the issue everywhere (e.g. work vs home)? If you have a network administrator, you might want to show this page to rule out any local firewalling issues.

    That host is not ours and so there's nothing I can do about its reachability.

  4. Bitbucket user reporter

    Actually I can reach amazonaws. I just tried uploading files that are smaller than 400KB, and the upload works as intended; anything larger it just hangs.

    Are there size restrictions now? I didn't have this issue two weeks ago.

  5. Erik van Zijst staff

    No, there are no restriction.

    Earlier you said your browser hung on that URL. Since your browser has a direct connection with Amazon, there's nothing we can see or do. What exactly do you see when uploading? Are there any errors that show up in your browser's web inspector (timeouts and such)? Or maybe things do work, but very slowly? Can you check for network activity while the browser seemingly hangs?

  6. Bitbucket user reporter

    This is what I see in chrome:

    In safari, the only request that shows up in the inspector is the mimeguess:

    There is no network activity or errors on both browsers after it hangs. I've even left it for over 15 minutes, and still no response.

  7. Erik van Zijst staff

    I cannot reproduce this problem. I was able to upload a file to your repo just fine.

    I can also see that you have uploaded many files in the past, one as recent as yesterday.

    Any chance you could swap computers and/or locations to give this another try? I cannot explain what you are seeing in Chrome there. It seems to claim it is still receiving data, even though it already has the 304 status code printed (which by definition means the request has ended).

  8. Guido Grazioli

    I am facing the same problem most often; I am trying to upload a 42Mbytes executable jar, after uploading 20 to 25% I get "The connection to bbuseruploads.s3.amazonaws.com was interrupted." , Error code: ERR_CONNECTION_RESET

  9. jun hu

    The issue happens when i download one 93mb python package file savReaderWriter==3.3.0 from bitbucket, my pip shows

    HTTPSConnectionPool(host='bbuseruploads.s3.amazonaws.com', port=443): Read timed out.
    
  10. Log in to comment