1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues


Issue #8561 duplicate

The better searching for receive repositories by bitbucket api

samuel hints
created an issue


There is some variables like page , pagelen, after in /api/2.0/repositories request.


Is there another variables !?

for example: values, values['has_wiki'] or has_wiki=1

Also I love this syntax for recieve data, just like FQL.

/api/3.0/?query=SELECT * FROM repositories WHERE has_wiki = 1

Comments (11)

  1. samuel hints reporter

    Another IDEA. :)

    We can to use only by query variables.

    We have here this variables. page, pagelen | limit, after and field_key , field_value , field_compare.

    The request will be like this:


    The results will be include all repositories that the has_wiki parameter not equal ( != ) to true.

    Another example:


    The results will be include all evzijst repositories .

    The field_compare can will be include this values.

    equal, not-equal, Like, greater-than, less-than, less-than-or-equal, greater-than-or-equal

  2. Erik van Zijst staff

    I initially closed this issue as resolved as it started out discussing the presently available parameters to to the repositories endpoint.

    Now that it has shifted towards adding repo search functionality I think we should close it as a duplicate of the older issue that you mentioned.

  3. Log in to comment